EPG123 Bug Reports

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Re: EPG123 Bug Reports

Post#541 » Thu Jun 15, 2017 2:04 am

Any clue why my WMC is displaying my guide listings as having 9 days of data considering I just successfully ran EPG123? For a bit it said it was indexing and once that was done, just 9 days (i have 14 days selected in EPG123).

Code: Select all
[2017-06-15 01:47:00Z]  Beginning epg123 update execution.
[2017-06-15 01:47:00Z] ===============================================================================
[2017-06-15 01:47:00Z] [ INFO] Beginning EPG123 update execution.
[2017-06-15 01:47:00Z] [ INFO] epg123 version 1.1.6 , DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: True , LogoOverride: True , AutoAddNew: True
[2017-06-15 01:47:00Z] [ INFO] Successfully retrieved TMDb configurations.
[2017-06-15 01:47:01Z] [ INFO] epg123 is up to date. version: 1.1.6
[2017-06-15 01:47:01Z] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[2017-06-15 01:47:01Z] Entering buildLineupServices() for 1 lineups.
[2017-06-15 01:47:01Z] [ INFO] Successfully retrieved the station mapping for lineup USA-WA63873-X.
[2017-06-15 01:47:01Z] Exiting buildLineupServices(). SUCCESS.
[2017-06-15 01:47:01Z] Entering getAllScheduleEntryMd5s() for 14 days on 465 stations.
[2017-06-15 01:47:07Z] [ INFO] Successfully retrieved Md5s for 465 station's daily schedules.
[2017-06-15 01:47:09Z] [ INFO] Found 2584 cached daily schedules.
[2017-06-15 01:47:12Z] [ INFO] Successfully retrieved 465 station's daily schedules.
[2017-06-15 01:47:18Z] [ INFO] Downloaded 1601 daily schedules.
[2017-06-15 01:47:26Z] [ INFO] Processed 4185 daily schedules for 465 stations.
[2017-06-15 01:47:26Z] Exiting getAllScheduleEntryMd5s(). SUCCESS.
[2017-06-15 01:47:26Z] Entering buildAllProgramEntries() for 29414 programs.
[2017-06-15 01:47:55Z] [ INFO] Found 21888 cached program descriptions.
[2017-06-15 01:48:00Z] [ INFO] Successfully retrieved 5000 program descriptions.
[2017-06-15 01:48:17Z] [ INFO] Successfully retrieved 2526 program descriptions.
[2017-06-15 01:48:24Z] [ INFO] Processed 29414 program descriptions.
[2017-06-15 01:48:24Z] Exiting buildAllProgramEntries(). SUCCESS.
[2017-06-15 01:48:24Z] Entering buildAllGenericSeriesInfoDescriptions() for 7339 series.
[2017-06-15 01:48:31Z] [ INFO] Found 6879 cached series descriptions.
[2017-06-15 01:48:32Z] [ INFO] Successfully retrieved 460 generic program descriptions.
[2017-06-15 01:48:32Z] [ INFO] Processed 7339 series descriptions.
[2017-06-15 01:48:32Z] Exiting buildAllGenericSeriesInfoDescriptions(). SUCCESS.
[2017-06-15 01:48:32Z] Entering getAllMoviePosters() for 2511 movies.
[2017-06-15 01:48:32Z] [ INFO] Found 1644 cached movie poster links.
[2017-06-15 01:48:34Z] [ INFO] Successfully retrieved artwork info for 500 programs.
[2017-06-15 01:49:12Z] [ INFO] Successfully retrieved artwork info for 367 programs.
[2017-06-15 01:49:49Z] [ INFO] Processed 2511 movie poster links.
[2017-06-15 01:49:49Z] Exiting getAllMoviePosters(). SUCCESS.
[2017-06-15 01:49:49Z] Entering getAllSeriesImages() for 7339 series.
[2017-06-15 01:49:49Z] [ INFO] Found 6195 cached series image links.
[2017-06-15 01:49:50Z] [ INFO] Successfully retrieved artwork info for 500 programs.
[2017-06-15 01:49:52Z] [ INFO] Successfully retrieved artwork info for 500 programs.
[2017-06-15 01:49:54Z] [ INFO] Successfully retrieved artwork info for 145 programs.
[2017-06-15 01:49:54Z] [ INFO] Processed 7340 series image links.
[2017-06-15 01:49:54Z] Exiting getAllSeriesImages(). SUCCESS.
[2017-06-15 01:49:54Z] [ INFO] Completed compiling keywords and keyword groups.
[2017-06-15 01:49:54Z] Entering writeMxf().
[2017-06-15 01:49:56Z] [ INFO] Completed save of mxf file.
[2017-06-15 01:49:56Z] Exiting writeMxf(). SUCCESS.
[2017-06-15 01:49:56Z] Entering writeImageArchive().
[2017-06-15 01:49:56Z] [ INFO] Completed save of image archive file.
[2017-06-15 01:49:56Z] Exiting writeImageArchive(). SUCCESS.
[2017-06-15 01:50:01Z] [ INFO] 3415 files deleted from the cache directory during cleanup.
[2017-06-15 01:50:01Z] [ INFO] Generated .mxf file contains 465 services, 7339 series, 29414 programs, and 46932 people with 9705 image links.
[2017-06-15 01:50:01Z] [ INFO] Completed EPG123 update execution. SUCCESS.
[2017-06-15 01:50:01Z] ====================== Beginning epg123 client execution. =====================
[2017-06-15 01:50:01Z] [ INFO] Import=True , Match=True , NoLogo=False
[2017-06-15 01:50:01Z] [ INFO] Beginning epg123 client execution.
[2017-06-15 01:50:02Z] [ INFO] import filename = C:\Users\Nathan\Downloads\epg123\epg123_v1.0.2_w7\epg123.mxf
[2017-06-15 01:52:04Z] [ INFO] Successfully imported .mxf file into Media Center. Exit code: 0
[2017-06-15 01:52:04Z] [ INFO] Completed importing "C:\Users\Nathan\Downloads\epg123\epg123_v1.0.2_w7\epg123.mxf"
[2017-06-15 01:52:08Z] [ INFO] Completed the automatch of lineup stations to tuner channels.
[2017-06-15 01:52:08Z] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\ReindexSearchRoot".
[2017-06-15 01:52:08Z] [ INFO] Successfully started the ReindexSearchRoot task. Exit code: 0
[2017-06-15 01:52:08Z] [ INFO] epg123Client mxf load and database reindex execution time was 00:02:06.6742226.
[2017-06-15 01:52:08Z] ====================== Completed epg123 client execution. =====================
[2017-06-15 01:52:08Z] [ INFO] Completed epg123 client execution.
[2017-06-15 01:52:10Z] [ INFO] epg123 update execution time was 00:05:09.9745445.


Also, is it just me or is the time wrong/weird? I just did this update (6:50PM-ish) and it is listted as 01:50 and such? Thanks for any help you can provide.
NathanP2007
 
Posts: 21
Joined: 12 June 2016

Post#542 » Thu Jun 15, 2017 2:12 am

Both of your issues have been discussed in recent threads/posts.

You only have 9 days of data due to a service issue:
viewtopic.php?f=99&t=10937

The time in the log has a Z at the end indicating "Zulu" which means it is in the UTC/GMT timezone. The next version of EPG123 will be changing that back to your local time.
Space
 
Posts: 1219
Joined: 2 June 2013

Post#543 » Thu Jun 15, 2017 2:52 am

Space wrote:Both of your issues have been discussed in recent threads/posts.

You only have 9 days of data due to a service issue:
viewtopic.php?f=99&t=10937

The time in the log has a Z at the end indicating "Zulu" which means it is in the UTC/GMT timezone. The next version of EPG123 will be changing that back to your local time.


Thank you! I tried to look around a bit but didn't see my problem. My bad.
NathanP2007
 
Posts: 21
Joined: 12 June 2016

Post#544 » Thu Jun 15, 2017 3:39 am

Space wrote:The next version of EPG123 will be changing that back to your local time.

Good timing. Next release is available for download.
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#545 » Thu Jun 15, 2017 10:21 pm

I can't set aschedlued task it is greyed out as are the automatically import guide data and automatically match stations. I've tried uninstall and reinstalled V1.1.7 no luck. Schedules direct and provider data are there just can't get into MCE.

Please & thanx :D
brianl8534
 
Posts: 2
Joined: 15 June 2017

Post#546 » Thu Jun 15, 2017 10:30 pm

brianl8534 wrote:I can't set aschedlued task it is greyed out as are the automatically import guide data and automatically match stations. I've tried uninstall and reinstalled V1.1.7 no luck. Schedules direct and provider data are there just can't get into MCE.

Please & thanx :D

Try hitting the button to delete the scheduled task then create a new one with a new time or the one already there (doesn't matter really). This should expose the other two options too.

I know, not intuitive but it is what it is..

Sent from my SM-G930P using Tapatalk
Sammy2
 
Posts: 1360
Joined: 24 August 2012
HTPC Specs: Show details

Post#547 » Fri Jun 16, 2017 12:46 am

The import and match functions are a part of the task. If the task is created, I lock the fields so the user knows exactly what the task will do when it is run. If there is no task, you can do whatever you want. To change the task, the existing one needs to be deleted and a new one created with you selection to import and/or match.
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#548 » Fri Jun 16, 2017 1:08 am

Brilliant. WOrked. Thanx so much.
brianl8534
 
Posts: 2
Joined: 15 June 2017

Post#549 » Mon Jun 19, 2017 5:22 pm

Just installed 1.1.8 & noticed that clicking on the "download add" didn't download any logo's. Is there anything special I need to do?
choliscott
 
Posts: 524
Joined: 19 December 2011
HTPC Specs: Show details

Post#550 » Mon Jun 19, 2017 5:31 pm

choliscott wrote:Just installed 1.1.8 & noticed that clicking on the "download add" didn't download any logo's. Is there anything special I need to do?

The download all button downloads all the logos provided by SD for your lineup stations. They are saved in the .\sdlogos folder only and does not get included in the guide. They are there for the user to modify and place in the .\logos folder for inclusion.
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#551 » Fri Jul 07, 2017 6:32 pm

Hi Everyone, EPG123 newb here.

Just installed EPG123 1.1.10 on W7 HTPC and experiencing 2 issues:

1) I have 3 HDHR CC (3 Tuner) setup - 2 with Cable Card and 1 without. I am having difficulty getting all 9 tuners to get set up correctly. I think I need to add 2 Lineups, instead of just the one, but wanted to know if I needed to set up tuners differently during live tv setup.

2) After adding a second lineup for OTA, i am getting the following error when trying to open WMC:

Windows Media Center has stopped working

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ehshell.exe
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: 4a5bd053
Problem Signature 04: mscorlib
Problem Signature 05: 2.0.0.0
Problem Signature 06: 55f8e01b
Problem Signature 07: 2d33
Problem Signature 08: 79
Problem Signature 09: System.Security.Security
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033

Any help is greatly appreciated.
kamu791
 
Posts: 3
Joined: 7 July 2017

Post#552 » Fri Jul 07, 2017 7:29 pm

kamu791 wrote:Hi Everyone, EPG123 newb here.

Just installed EPG123 1.1.10 on W7 HTPC and experiencing 2 issues:

1) I have 3 HDHR CC (3 Tuner) setup - 2 with Cable Card and 1 without. I am having difficulty getting all 9 tuners to get set up correctly. I think I need to add 2 Lineups, instead of just the one, but wanted to know if I needed to set up tuners differently during live tv setup.

2) After adding a second lineup for OTA, i am getting the following error when trying to open WMC:

Windows Media Center has stopped working

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ehshell.exe
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: 4a5bd053
Problem Signature 04: mscorlib
Problem Signature 05: 2.0.0.0
Problem Signature 06: 55f8e01b
Problem Signature 07: 2d33
Problem Signature 08: 79
Problem Signature 09: System.Security.Security
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033

Any help is greatly appreciated.

For the 3 primes, it seems to work best if after Step 1, you cycle power on all the primes for WMC to see them again correctly. I am assuming your 2 primes are "Digital Cable" in the setup and the third is "Digital Cable (QAM)"? I think that is the only thing you need to do special which would be normal with MS/Rovi setup as well.

Adding on OTA lineup (in EPG123 I presume) shouldn't matter at all.

I think I'm going to need a bit more detail on how far you got in the setup, what you have done trying to get the tuners setup, and anything leading up to the CLR error.
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#553 » Fri Jul 07, 2017 8:10 pm

garyan2 wrote:
kamu791 wrote:Hi Everyone, EPG123 newb here.

Just installed EPG123 1.1.10 on W7 HTPC and experiencing 2 issues:

1) I have 3 HDHR CC (3 Tuner) setup - 2 with Cable Card and 1 without. I am having difficulty getting all 9 tuners to get set up correctly. I think I need to add 2 Lineups, instead of just the one, but wanted to know if I needed to set up tuners differently during live tv setup.

2) After adding a second lineup for OTA, i am getting the following error when trying to open WMC:

Windows Media Center has stopped working

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: ehshell.exe
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: 4a5bd053
Problem Signature 04: mscorlib
Problem Signature 05: 2.0.0.0
Problem Signature 06: 55f8e01b
Problem Signature 07: 2d33
Problem Signature 08: 79
Problem Signature 09: System.Security.Security
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033

Any help is greatly appreciated.

For the 3 primes, it seems to work best if after Step 1, you cycle power on all the primes for WMC to see them again correctly. I am assuming your 2 primes are "Digital Cable" in the setup and the third is "Digital Cable (QAM)"? I think that is the only thing you need to do special which would be normal with MS/Rovi setup as well.

Adding on OTA lineup (in EPG123 I presume) shouldn't matter at all.

I think I'm going to need a bit more detail on how far you got in the setup, what you have done trying to get the tuners setup, and anything leading up to the CLR error.



Thanks for the prompt response. I think I added the OTA lineup and ran the guide update after which I started getting the WMC error.

I think I am going to go back to a last good restore point pre-EPG123 and re-run the install. Keep you all posted. Will definitely remember to run the step 1 prompt and tuner salad at that point too. Thanks!
kamu791
 
Posts: 3
Joined: 7 July 2017

Post#554 » Sat Jul 08, 2017 12:54 am

Checking back in.

I went back to the last restore point and was able to re-configure EPG123 correctly. Looks like I have all the tuners running and trying to get the OTA lineup and channels added to the guide, but they are saying no data available so far. I might just be impatient.

From what I have seen so far, this is leaps and bounds better than Rovi. Thanks Gary! You truly are a liberator for WMC!

I'll give the indexing some time and check back in later.
kamu791
 
Posts: 3
Joined: 7 July 2017

Post#555 » Sat Jul 08, 2017 12:57 am

What do you mean by trying to get the OTA lineup and channels added?
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#556 » Sat Jul 08, 2017 3:47 am

FYI...I had to do the save and execute twice for things to work. You should also say not to close the client gui as once the regular execute finished, the bar on the client gui loaded, but then it was blank on the lineup page. So I did the execute by # and got a nice bug report (see below). I had to force close and then when I reopened it, it suddenly had the left and right lineup/guides populated, so it worked but with bugs. Just sent a donation! but wanted to post the error code for your info. Not sure what happened as I followed instructions exactly...but it works!
/?
I have HD homerun with cablecard, cablevision, WMC 7. Perhaps there was just a lag or something in the lineup loading and getting into WMC

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
Code: Select all
************** Exception Text **************
Microsoft.MediaCenter.Store.StoredObjectUpdateException: Unable to commit the StoredObject of id 1C000000017BE5 back to the ObjectStore. Initial revision = 0, previous revision = 0, current revision = 3
   at Microsoft.MediaCenter.Store.StoredObject.Update()
   at epg123.clientForm.mergedChannelListView_ItemChecked(Object sender, ItemCheckedEventArgs e)
   at System.Windows.Forms.ListView.WmReflectNotify(Message& m)
   at System.Windows.Forms.ListView.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
epg123Client
    Assembly Version: 1.1.10.7
    Win32 Version: 1.1.10.7
    CodeBase: file:///C:/epg123/epg123Client.exe
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
mcepg
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/mcepg/6.1.0.0__31bf3856ad364e35/mcepg.dll
----------------------------------------
mcstore
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/mcstore/6.1.0.0__31bf3856ad364e35/mcstore.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
ptb0endm
    Assembly Version: 1.1.10.7
    Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
mcstoredb
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850)
    CodeBase: file:///C:/Windows/assembly/GAC_64/mcstoredb/6.1.0.0__31bf3856ad364e35/mcstoredb.dll
----------------------------------------
ehiProxy
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/ehiProxy/6.1.0.0__31bf3856ad364e35/ehiProxy.dll
----------------------------------------
Microsoft.MediaCenter.UI
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.MediaCenter.UI/6.1.0.0__31bf3856ad364e35/Microsoft.MediaCenter.UI.dll
----------------------------------------
BDATunePIA
    Assembly Version: 6.1.0.0
    Win32 Version: 6.1.7601.17514 (win7sp1_rtm.101119-1850)
    CodeBase: file:///C:/Windows/assembly/GAC_64/BDATunePIA/6.1.0.0__31bf3856ad364e35/BDATunePIA.dll
----------------------------------------
System.Core
    Assembly Version: 3.5.0.0
    Win32 Version: 3.5.30729.5420 built by: Win7SP1
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Core/3.5.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.


For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
gsimmons2005
 
Posts: 4
Joined: 8 July 2017

Post#557 » Sat Jul 08, 2017 4:11 am

gsimmons2005 wrote:FYI...I had to do the save and execute twice for things to work. You should also say not to close the client gui as once the regular execute finished, the bar on the client gui loaded, but then it was blank on the lineup page. So I did the execute by # and got a nice bug report (see below). I had to force close and then when I reopened it, it suddenly had the left and right lineup/guides populated, so it worked but with bugs. Just sent a donation! but wanted to post the error code for your info. Not sure what happened as I followed instructions exactly...but it works!

Hadn't actually tested out that scenario. I want to make sure I understand ... while the mxf file was being imported, you clicked the [# Number] button? Of was it after the import was complete but the left and right listviews were not refreshed yet?
User avatar
garyan2
 
Posts: 2248
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#558 » Sat Jul 08, 2017 1:14 pm

The status bar had finished imported but it was blank after 100%, so I was curious what was going on. I then tried the # button and got that error. Force closed and then reopened and it all was suddently populated. This happened after the first try, but without me clicking #, hence having to do save and execute again, but 2nd time I tried the number match.

Is there a delay in 123client loading up the lineups once the 123 app does its things? I have a ton of channels.
gsimmons2005
 
Posts: 4
Joined: 8 July 2017

Post#559 » Sat Jul 08, 2017 1:36 pm

I'm new to EPG123 since my listings from Microsoft stopped showing up. I am a long time user of WMC.

Forgive me if this has been discussed elsewhere. I searched, but could not find anything.

Background: I have 4 HTPCs with 2 HDHomeRun Prime Tuners and 1 HDHomeRun Connect Tuner. Of course WMC only lets one use 4 of the 6 tuners in the two primes. After much experimentation, I have deduced the WMC uses the tuners in the order they are added. The HDHomeRun drivers fortunately pool the tuners out of one Prime so that if you choose 3 tuners from one Prime and then one tuner from the second Prime, while WMC is using what it thinks is its first tuner, it is actually using any tuner in that Prime. But when it gets to the 4th tuner, it then switches to the other Prime. In other words, unfortunately, the drivers do not pool across Primes. If you follow all that, I realized that the correct way to set up the 4 HTPCs to minimize conflicts is to always use 3 from one and 1 from the other, two of four starting with the first and the other two starting with the second. If you simply pick one from the first and then three from the second, then if there is no tuner left in the first Prime, you get a tuner conflict. So, it's better to let pairs each share 3 from one then jump to the other. This requires manual tuner setup on two of the HTPCs: first I add three tuners from the second Prime, and then one from the first.

It has worked very well for years (except for the crappy Rovi listings). But, with EPG123, when I use manual setup like this, I get two channels in the guide for every actual channel. One channel has the tuners from the second prime, the other has the one from the first prime. For now, I can just drop down to only 3 tuners in these HTPCs to avoid this issue. But maybe it could be looked into?
Sparkee
 
Posts: 2
Joined: 8 July 2017

Post#560 » Sat Jul 08, 2017 2:52 pm

I don't use Primes myself but I believe the answer here is quite a bit simpler. Use TunerSalad to remove the 4-tuner per type restriction in WMC. It's a common issue with CableCARD tuners that have more than 4 total tuners and the solution is just to make registry changes that allow more than 4 in WMC. Ceton has a specific tool for it but Prime users just use T-S.
http://www.thegreenbutton.tv/wiki/index ... TunerSalad
glorp
 
Posts: 320
Joined: 23 September 2012

PreviousNext

Return to EPG123



Who is online

Users browsing this forum: No registered users and 2 guests

cron