[ERROR] PrimaryChannel.Lineup is null.

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

[ERROR] PrimaryChannel.Lineup is null.

Post#1 » Wed Jan 10, 2018 4:28 pm

Hi,

I upgraded to 1.1.18. Apparently, I removed some channels--I don't recall which, but epg123 lists them in the log. I realized that I must have removed 201/WBBMDT in error, so I restored it. Then I upgraded to 1.1.19. Now, I receive these "PrimaryChannel.Lineup is null" errors when I run the client, and it seems EPG123 isn't downloading (or importing?) some channels (maybe because it crashes). I'm also not clear on why the log says that some channels are "already assigned." AFAIK, I'm using auto-match, not doing anything manually. The client also crashes after logging all the "already assigned" messages.

Unfortunately, I don't seem to be able to attach the log file, so it's here: https://pastebin.com/HhBnKkZL
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#2 » Wed Jan 10, 2018 5:30 pm

What version did you upgrade from? The error messages you are getting have been a part of the build for quite some time. I believe the PrimaryChannel.Lineup is null message is close to a year old now. I'll start with that one first.

In developing 1.1.0 a year ago, we found that some merged channels had null values in fields that should have something. The particular message is the channel assigned to be the PrimaryChannel in the merged channel has no lineup ... should be impossible. The channels had to come from somewhere. The null entry prevents me from populating that particular channel in the client so I spit out the error. I suspect that this is due to how Guide Tool handles the subscribe/unsubscribe operation. Have you used Guide Tool in the past? Based on this alone I suspect you might have upgraded from v1.0.2?

To support a v1.0.2 or earlier upgraded as well is the "already assigned" messages. These will show up when the automatch routine runs and there is an "EPG123" lineup assigned to the channel already but it is not the one the client thinks it should be. The reason I suspect this is due to the v1.0.2 or earlier upgrade is because in v1.1.0 I changed the channel unique ID to incorporate the lineup name as well as the station ID and channel number. A quick way to get rid of these would be to use the client, select all channels on the left side (Ctrl-A), right-click and select 'Unsubscribe'. Then click the Match by: [# Number] button above the channels.

The PrimaryChannel.Lineup is null message might take further action to correct ... we'll see.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#3 » Wed Jan 10, 2018 5:35 pm

I upgraded from 1.1.17. I use PC Monitor Manager to send me any warnings/errors posted to the Event Log, and this is the first time I've seen the PrimaryChannel.Lineup error.

Perhaps those "already assigned" messages were because I selected the wrong lineup in the client when I did an auto-match. I was trying to correct those matches, and I selected my local "Wide Open West" lineup on the right instead of the "EPG123 Wide Open West" lineup. (I'm sorry. I write software to process the SD listings data and this is still confusing for me.) :)

So, I re-did the auto-match in the client using the "EPG WOW" lineup. That seems to eliminate the "already assigned" messages, but the client still crashes after emitting the "Skipped matching" message.

https://pastebin.com/QkXwkbxf
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#4 » Wed Jan 10, 2018 5:49 pm

12noon wrote:Perhaps those "already assigned" messages were because I selected the wrong lineup in the client when I did an auto-match. I was trying to correct those matches, and I selected my local "Wide Open West" lineup on the right instead of the "EPG123 Wide Open West" lineup. (I'm sorry. I write software to process the SD listings data and this is still confusing for me.) :)

You are correct. I will correct my statement above for the "already assigned" message to be for any channel that has any lineup assigned that is not the scanned lineup ... not just an EPG123 lineup.

12noon wrote:... but the client still crashes after emitting the "Skipped matching" message.

Can you manually unsubscribe and re-subscribe WBBMDT2 to channel 172? Something funny about that channel. Is it present on the left side of the client? It may be one of the channels that have the PrimaryChannel.Lineup is null. If so, try to remove the guide listings from channel 172 in WMC. Warning: this may result in that channel no longer being available.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#5 » Wed Jan 10, 2018 6:58 pm

Yes, 172 is on the left-hand side. I unsubscribed it and used auto-assign again. I think that's done the trick. The log looks as if epg123 didn't crash on the import this time.
Code: Select all
[1/10/2018 12:06:43 PM] ===============================================================================
[1/10/2018 12:06:43 PM]  Beginning epg123 client execution.
[1/10/2018 12:06:43 PM] ===============================================================================
[1/10/2018 12:06:43 PM] [ INFO] Beginning epg123 client execution. 2018-01-10 18:06:43Z
[1/10/2018 12:06:43 PM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: True
[1/10/2018 12:06:43 PM] [ INFO] epg123 client version: 1.1.19 for Win7
[1/10/2018 12:06:45 PM] Entering importMxfFile() for file "D:\EPG123\epg123.mxf"
[1/10/2018 12:09:59 PM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[1/10/2018 12:09:59 PM] Exiting importMxfFile(). SUCCESS.
[1/10/2018 12:10:08 PM] ===============================================================================
[1/10/2018 12:10:08 PM]  Activating the epg123 client GUI. version 1.1.19 for Win7
[1/10/2018 12:10:08 PM] ===============================================================================
[1/10/2018 12:10:08 PM] [ INFO] Successfully queried the Task Scheduler for status. ERROR: Access is denied. 
[1/10/2018 12:10:09 PM] [ERROR] PrimaryChannel.Lineup is null.
[1/10/2018 12:10:09 PM] [ERROR] PrimaryChannel.Lineup is null.
[1/10/2018 12:10:11 PM] [ERROR] PrimaryChannel.Lineup is null.
[1/10/2018 12:10:11 PM] [ERROR] PrimaryChannel.Lineup is null.
[1/10/2018 12:16:31 PM] ===============================================================================
[1/10/2018 12:16:31 PM]  Beginning epg123 update execution.
[1/10/2018 12:16:31 PM] ===============================================================================
[1/10/2018 12:16:31 PM] [ INFO] Beginning EPG123 update execution. 2018-01-10 18:16:31Z
[1/10/2018 12:16:31 PM] [ INFO] DaysToDownload: 21 , TheTVDBNumbers : True , PrefixEpisodeTitle: True , PrefixEpisodeDescription : True , AppendEpisodeDesc: False , OADOverride : True , TMDbCoverArt: True , IncludeSDLogos : False , AutoAddNew: True
[1/10/2018 12:16:32 PM] [ INFO] Token request successful. serverID: 20141201.web.3
[1/10/2018 12:16:32 PM] [ INFO] Status request successful. account expires: 2018-06-19T22:21:51Z , lineups: 2/4 , lastDataUpdate: 2018-01-10T13:38:02Z
[1/10/2018 12:16:32 PM] [ INFO] system status: Online , message: No known issues.
[1/10/2018 12:16:32 PM] [ INFO] epg123 is up to date. version: 1.1.19
[1/10/2018 12:16:32 PM] [ INFO] Successfully retrieved TMDb configurations.
[1/10/2018 12:16:33 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[1/10/2018 12:16:33 PM] Entering buildLineupServices() for 2 lineups.
[1/10/2018 12:16:33 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-IL58819-X.
[1/10/2018 12:16:34 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-OTA-60005.
[1/10/2018 12:16:34 PM] Exiting buildLineupServices(). SUCCESS.
[1/10/2018 12:16:34 PM] Entering getAllScheduleEntryMd5s() for 21 days on 232 stations.
[1/10/2018 12:16:38 PM] [ INFO] Successfully retrieved Md5s for 232 station's daily schedules.
[1/10/2018 12:16:44 PM] [ INFO] Found 4866 cached daily schedules.
[1/10/2018 12:16:44 PM] [ INFO] Downloaded 0 daily schedules.
[1/10/2018 12:18:01 PM] [ INFO] Processed 4866 daily schedules for 232 stations.
[1/10/2018 12:18:01 PM] Exiting getAllScheduleEntryMd5s(). SUCCESS.
[1/10/2018 12:18:01 PM] Entering buildAllProgramEntries() for 32273 programs.
[1/10/2018 12:29:13 PM] [ INFO] Found 32273 cached program descriptions.
[1/10/2018 12:29:13 PM] [ INFO] Processed 32273 program descriptions.
[1/10/2018 12:29:13 PM] Exiting buildAllProgramEntries(). SUCCESS.
[1/10/2018 12:29:13 PM] Entering buildAllGenericSeriesInfoDescriptions() for 3426 series.
[1/10/2018 12:29:52 PM] [ INFO] Found 3426 cached series descriptions.
[1/10/2018 12:29:52 PM] [ INFO] Processed 3426 series descriptions.
[1/10/2018 12:29:52 PM] Exiting buildAllGenericSeriesInfoDescriptions(). SUCCESS.
[1/10/2018 12:29:52 PM] Entering getAllMoviePosters() for 1690 movies.
[1/10/2018 12:29:52 PM] [ INFO] Found 1680 cached movie poster links.
[1/10/2018 12:29:53 PM] [ INFO] Successfully retrieved artwork info for 10 programs.
[1/10/2018 12:29:53 PM] [ INFO] TMDb catalog search for "The Brave Lion" from 1978 found 0 results.
[1/10/2018 12:29:53 PM] [ INFO] TMDb catalog search for "The Brave Lion" from 1977 found 0 results.
[1/10/2018 12:29:53 PM] [ INFO] TMDb catalog search for "The Brave Lion" from 1979 found 0 results.
[1/10/2018 12:29:53 PM] [ INFO] Processed 1690 movie poster links.
[1/10/2018 12:29:53 PM] Exiting getAllMoviePosters(). SUCCESS.
[1/10/2018 12:29:53 PM] Entering getAllSeriesImages() for 3426 series.
[1/10/2018 12:29:53 PM] [ INFO] Found 3303 cached series image links.
[1/10/2018 12:29:54 PM] [ INFO] Successfully retrieved artwork info for 123 programs.
[1/10/2018 12:29:54 PM] [ INFO] Processed 3426 series image links.
[1/10/2018 12:29:54 PM] Exiting getAllSeriesImages(). SUCCESS.
[1/10/2018 12:29:54 PM] [ INFO] Completed compiling keywords and keyword groups.
[1/10/2018 12:29:54 PM] Entering writeMxf().
[1/10/2018 12:29:56 PM] [ INFO] Completed save of mxf file.
[1/10/2018 12:29:56 PM] Exiting writeMxf(). SUCCESS.
[1/10/2018 12:29:56 PM] Entering writeImageArchive().
[1/10/2018 12:29:56 PM] [ INFO] Completed save of image archive file.
[1/10/2018 12:29:56 PM] Exiting writeImageArchive(). SUCCESS.
[1/10/2018 12:31:52 PM] [ INFO] 0 files deleted from the cache directory during cleanup.
[1/10/2018 12:31:52 PM] [ INFO] Generated .mxf file contains 232 services, 3426 series, 32273 programs, and 46271 people with 5020 image links.
[1/10/2018 12:31:52 PM] [ INFO] Completed EPG123 update execution. SUCCESS.
[1/10/2018 12:31:52 PM] [ INFO] epg123 update execution time was 00:15:21.4887062.
[1/10/2018 12:31:53 PM] ===============================================================================
[1/10/2018 12:31:53 PM]  Beginning epg123 client execution.
[1/10/2018 12:31:53 PM] ===============================================================================
[1/10/2018 12:31:53 PM] [ INFO] Beginning epg123 client execution. 2018-01-10 18:31:53Z
[1/10/2018 12:31:53 PM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: False
[1/10/2018 12:31:53 PM] [ INFO] epg123 client version: 1.1.19 for Win7
[1/10/2018 12:31:55 PM] Entering importMxfFile() for file "D:\EPG123\epg123.mxf"
[1/10/2018 12:35:10 PM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[1/10/2018 12:35:10 PM] Exiting importMxfFile(). SUCCESS.
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#6 » Wed Jan 10, 2018 10:35 pm

If that is how your log ends, then no, it is still kicking out during the automatch routine. I just took a look at my code and see that the PrimaryChannel.Lineup is null problem for the GUI will also be a problem with the automatch.

I just built a new version of the client I would like you to try out. It has try/catch in the automatch routine and will provide more information on which merged channels have the null problems.
http://epg123.garyan2.net/downloads/epg ... t_beta.zip
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#7 » Wed Jan 10, 2018 11:10 pm

12noon wrote:... I selected my local "Wide Open West" lineup on the right instead of the "EPG123 Wide Open West" lineup. (I'm sorry. I write software to process the SD listings data and this is still confusing for me.) :)

Was the local "Wide Open West" lineup homebrewed or is this from MS/Rovi? Just curious.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#8 » Thu Jan 11, 2018 1:17 am

Yes, I've seen it crash during the auto-match. I'll try out that beta as soon as I can, but it might not be until Sunday because my son's going back to college Sunday morning.

Can you please give me a portable build though? I don't install it.

No, Wide Open West is a local cable company: IL58819:X (Wide Open West - Chicagoland Digital)
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#9 » Thu Jan 11, 2018 3:43 am

12noon wrote:Yes, I've seen it crash during the auto-match. I'll try out that beta as soon as I can, but it might not be until Sunday because my son's going back to college Sunday morning.

Can you please give me a portable build though? I don't install it.

No, Wide Open West is a local cable company: IL58819:X (Wide Open West - Chicagoland Digital)
The zip file is just the client executable for all the OS versions. You can extract it to anywhere and execute from there.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#10 » Sun Jan 14, 2018 7:17 pm

Sorry this took so long.

This log is from running the client you sent and exiting. Then I ran the scheduled-task's steps (epg123.exe and the test build of epg123client.exe).

Code: Select all
D:\EPG123\epg123.exe -update
D:\EPG123\epg123Client.exe -i "epg123.mxf" -match

https://pastebin.com/zXRSHLxP
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#11 » Sun Jan 14, 2018 7:51 pm

12noon wrote:Sorry this took so long.

This log is from running the client you sent and exiting. Then I ran the scheduled-task's steps (epg123.exe and the test build of epg123client.exe).

Code: Select all
D:\EPG123\epg123.exe -update
D:\EPG123\epg123Client.exe -i "epg123.mxf" -match

https://pastebin.com/zXRSHLxP

Well that was unexpected. It looks like there are actually 2 different things going on here. The PrimaryChannel.Lineup is null errors are your ATSC channels 7.3 and 26.3. You may be able to Edit Channels in WMC to assign a/any guide listing to the channels and then change back to "Show no listings for this channel". WMC may "repair" the channel ... or it may make the channel disappear. With ATSC, the easiest thing to do to repair/rebuild the tuners so they are clean is to go to TV Signal->Scan for More Channels, click the [Delete All] button and then [Scan again] button. The guide listings will need to be reassigned, but you're guaranteed to remove any errors for those channels.

Because I was assuming the client failure during the automatch routine was related to the null errors, the beta client wasn't looking in the right place. I also have no real place to look except everywhere. Is there an error window that pops up when the exception occurs? Can you capture that text?
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#12 » Mon Jan 15, 2018 1:07 am

I'll try to fix up those channels.

I'm afraid the only error window I've seen is the transient version of the "The app is crashing" window. Nothing with a stack trace or any other information appears.
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#13 » Tue Jan 16, 2018 2:07 am

I'll work on building another client to capture more error data, but in the mean time I hope you are running EPG123 with the 'Automatically match ...' feature disabled? Am I right in assuming you have tried that and the client finishes correctly? If not, then I am totally looking in the wrong place.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#14 » Tue Jan 16, 2018 1:05 pm

Sorry, no, I'm using auto-match (and auto-add new channels). I don't (intentionally) manually map any stations to channels. BTW, last night, I tried to 7.3 to "Do not show listings" in WMC and WMC crashed. Fun stuff.
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#15 » Tue Jan 16, 2018 2:17 pm

This morning, the scheduled task did this. I didn't see this happen--it's an automated notification--but my guess is that WMC crashed again. IDK if it's a side-effect of WMC's crash last night or what.

Code: Select all
7:58:47 AM - Beginning epg123 client execution. 2018-01-16 13:58:47Z
8:01:55 AM - Error using loadmxf.exe to import new guide information. Exit code: -1
8:01:55 AM - Failed to import .mxf file. Exiting.


The funny thing is that I'm not even using 26.3 or 7.3--they're unchecked in the EPG123 apps.

Unless you have a different suggestion, tonight, I think I'll try enabling the channels in WMC, assign a different listing to each channel, then disable them again. In EPG123, I'll enable them, unsubscribe, and auto-match--just to be sure they're auto-matched. Then I'll run EPG123 and see what happens.
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#16 » Wed Jan 17, 2018 4:20 am

12noon wrote:This morning, the scheduled task did this. I didn't see this happen--it's an automated notification--but my guess is that WMC crashed again. IDK if it's a side-effect of WMC's crash last night or what.

Code: Select all
7:58:47 AM - Beginning epg123 client execution. 2018-01-16 13:58:47Z
8:01:55 AM - Error using loadmxf.exe to import new guide information. Exit code: -1
8:01:55 AM - Failed to import .mxf file. Exiting.


The funny thing is that I'm not even using 26.3 or 7.3--they're unchecked in the EPG123 apps.

Unless you have a different suggestion, tonight, I think I'll try enabling the channels in WMC, assign a different listing to each channel, then disable them again. In EPG123, I'll enable them, unsubscribe, and auto-match--just to be sure they're auto-matched. Then I'll run EPG123 and see what happens.

Sorry, it's been a hellishly long day at work today. The automatch isn't doing anything right now for you except throwing an exception and crashing the program. If you could run it without automatch enabled, and no exception is thrown, then that will exonerate some of my code from being the issue.

With ATSC, the easiest thing to do to repair/rebuild the tuners so they are clean is to go to settings->TV->TV Signal->Scan for More Channels, click the [Delete All] button and then [Scan again] button. This will require the channels to be matched with the listings again, but that is extremely easy to do manually in the client GUI. Just click the Match by: [# Number] button. This will eliminate the PrimaryChannel.Lineup is null errors, but I doubt it will help with the other issue of executing the automatch.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#17 » Wed Jan 17, 2018 6:13 am

No worries. As a software dev myself, I totally know how it goes.

https://pastebin.com/AuKWbSQA

Whenever I tried to edit the listing of 26.3 or 7.3 in WMC, WMC crashed. So I figured if I could download a valid listing of those channels, maybe THEN I could disable them. I mucked about in the 123 apps to make sure I had the right channels selected and the right lineups subscribed. Then I noticed that the client wrote to the log that every channel was "already assigned." Weird.

I saw your post, so I deleted and re-scanned the channels, did an auto-match #, and did another EPG123 update. This one seems to have gone swimmingly. All the "already assigned" messages are gone. Not sure why. I only auto-matched the OTA lineup.

We'll see how things go in the morning at the regularly-scheduled update.

Oh, there was a crash of the EPG123 client when I pressed Auto-match #. Possibly because no channel was selected in a list? I took a screenshot of the stack trace. Basically, ListViewItemCollection doesn't like an index of -1. (And, really, who does?) ;-)

https://i.imgur.com/aGG72Zn.png
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#18 » Wed Jan 17, 2018 6:29 am

12noon wrote:Oh, there was a crash of the EPG123 client when I pressed Auto-match #. Possibly because no channel was selected in a list? I took a screenshot of the stack trace. Basically, ListViewItemCollection doesn't like an index of -1. (And, really, who does?) ;-)

https://i.imgur.com/aGG72Zn.png

All right, that gave me a chuckle. :thumbup:

Before I jump down a rabbit hole, just to be sure... when you clicked the Auto-match # button, were there an channels populated on the left side at the time? The value of -1 is the index number of the ListViewItem in the ListViewItemCollection. The only thing I can think of right now is if you had the client open before, during, and after the delete and scan of the channels in WMC. Without a refresh of the client listviews, the ATSC merged channels on the left side would be pointing to some invalid database entries.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#19 » Wed Jan 17, 2018 2:26 pm

Yes, there were channels listed on the left when I pressed Auto-match #. It's possible, but I try to be careful to close the EPG123 apps before running WMC--certainly before I do anything in WMC that might affect the channels. I'm 99.99% certain no EPG123 app was running when I used WMC to delete and re-scan the channels. Of course, it's possible I screwed up and left it running, but I'm virtually certain that I wouldn't have.

Oh, and apparently things didn't go well after all as I seem to have no listings in WMC. Sigh. (Or, at least, no scheduled recordings anymore. Back to fiddling...)

Update 1: It was the "already assigned" issue again. I ran the client, selected all channels on the left, Unsubscribe, imported the MXF that was created this morning. No errors in the log. We'll see what WMC thinks...

Update 2: Apparently nothing. There's no new data, and WMC doesn't say it's indexing. I assume Manual import doesn't do what I think it does, so I'm doing a Save & Execute from epg123.exe...

Update 3: The "already assigned" errors are back. Latest log: https://pastebin.com/L65v6FXG I really don't get it. When one presses Auto-match #, what lineup should be selected on the right? I thought I should select my actual lineup, but should I select one of the "EPG ..." lineups? I don't recall seeing this in the doc. The PDF's screenshot shows the "EPG ..." lineups being selected. I'll give that a go. (I'm not clear why this is necessary. Perhaps because I screwed up something in the client? It'd be cool if there were some way to "reset" the client so the auto-match worked again. But, perhaps, I don't understand what's happening under the covers.)

Update 4: Unsubscribed all channels. Auto-match # with both "EPG123 ..." lineups (OTA and Cable). Save & Execute. Waiting...
User avatar
12noon
 
Posts: 63
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital
USA-IL58819-X

Post#20 » Wed Jan 17, 2018 3:20 pm

Where is this other/actual lineup coming from? Unless you still have Rovi being downloaded to your WMC database there should only be EPG123... lineups.

To answer your question; Yes. The EPG123 lineups should be selected on the right when performing an automatch. This is why you are getting the "already assigned" notifications. You have a lineup channel from a non-EPG123 lineup already assigned to the merged channel. Also, once you have the EPG123 lineup channels assigned, you will see your scheduled recordings get populated.
User avatar
garyan2
 
Posts: 2612
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Next

Return to EPG123



Who is online

Users browsing this forum: No registered users and 1 guest

cron