Update task not working

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Update task not working

Post#1 » Fri Sep 01, 2017 5:19 pm

Hi all,
The nightly task to update the listings is not working. If I look at the GUI screen it says that the task ran successfully with exit code zero but the .mxf file is not updated. The Task Scheduler also says the task ran successfully. If I do "save & execute" in the GUI then the listings are correctly updated.
Any advice/suggestions would be appreciated.
Many thanks,
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#2 » Fri Sep 01, 2017 5:26 pm

It sounds like your task is client mode only. Open the EPG123 Client and look in the Scheduled Task group. Is the "Full Mode" selected or the "Client Mode"?

If it is Client Mode, then delete the task, select Full Mode, and create the task again.
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#3 » Fri Sep 01, 2017 10:57 pm

Hi Gary, thanks for the swift response.
Yes, Client mode was selected. Changed to Full Mode, I'll report back tomorrow after the task runs tonight.
Many thanks,
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#4 » Sat Sep 02, 2017 9:38 am

I think I screwed up modifying the task; redone, let's see what happens tonight.
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#5 » Sun Sep 03, 2017 8:17 am

Task executed successfully at 3:00am Sep 03 but .MXF file not updated, still time-stamped 9:07am Sep 02 from my last manual run. It's definitely set to run in Full Mode.
I am running ver 1.13 on Windows 10 - any further suggestions welcome.
Many thanks,
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#6 » Sun Sep 03, 2017 3:02 pm

Stanno wrote:Task executed successfully at 3:00am Sep 03 but .MXF file not updated, still time-stamped 9:07am Sep 02 from my last manual run. It's definitely set to run in Full Mode.
I am running ver 1.13 on Windows 10 - any further suggestions welcome.
Many thanks,
Brian

Could you post the contents of the trace.log file for your 3AM update? Please remember to paste inside [Code ] tags.
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#7 » Sun Sep 03, 2017 6:37 pm

Hi,
Sorry, don't understand your comment about [Code ] tags.

Here's a paste from the file:
[02/09/2017 10:35:22] ===============================================================================
[02/09/2017 10:35:22] Activating the epg123 client GUI. version 1.1.13 for Win8.1
[02/09/2017 10:35:22] ===============================================================================
[02/09/2017 10:35:22] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:35:41] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:35:41] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[02/09/2017 10:35:47] [ INFO] Successfully deleted the daily update task from Task Scheduler.
[02/09/2017 10:35:47] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:35:52] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:35:52] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[02/09/2017 10:35:56] [ INFO] Successfully deleted the daily update task from Task Scheduler.
[02/09/2017 10:35:56] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:36:22] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:36:22] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[03/09/2017 09:07:47] ===============================================================================
[03/09/2017 09:07:47] Activating the epg123 client GUI. version 1.1.13 for Win8.1
[03/09/2017 09:07:47] ===============================================================================
[03/09/2017 09:07:47] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 03/09/2017 02:00:06; Exit: 0x00000000

Hope that's OK,
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#8 » Sun Sep 03, 2017 6:43 pm

Stanno wrote:Hi,
Sorry, don't understand your comment about [Code ] tags.

Here's a paste from the file:
Code: Select all
[02/09/2017 10:35:22] ===============================================================================
[02/09/2017 10:35:22]  Activating the epg123 client GUI. version 1.1.13 for Win8.1
[02/09/2017 10:35:22] ===============================================================================
[02/09/2017 10:35:22] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:35:41] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:35:41] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[02/09/2017 10:35:47] [ INFO] Successfully deleted the daily update task from Task Scheduler.
[02/09/2017 10:35:47] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:35:52] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:35:52] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[02/09/2017 10:35:56] [ INFO] Successfully deleted the daily update task from Task Scheduler.
[02/09/2017 10:35:56] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[02/09/2017 10:36:22] [ INFO] Successfully created the daily update task in Task Scheduler for 02:00.
[02/09/2017 10:36:22] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00041303
[03/09/2017 09:07:47] ===============================================================================
[03/09/2017 09:07:47]  Activating the epg123 client GUI. version 1.1.13 for Win8.1
[03/09/2017 09:07:47] ===============================================================================
[03/09/2017 09:07:47] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 03/09/2017 02:00:06; Exit: 0x00000000


Hope that's OK,
Brian

Do you have two different installs of EPG123? The log file here shows nothing happened at 0200, but your task status said something did and was successful (exit code 0x00000000).
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#9 » Sun Sep 03, 2017 6:45 pm

Take a look at your scheduled task in "Task Scheduler". You will see what folder it is pointing to.

2017-09-03.png
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#10 » Sun Sep 03, 2017 8:24 pm

My task looks just like that (although I have a different program path).

Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#11 » Sun Sep 03, 2017 9:36 pm

The trace.log file information you pasted above was from the same program path as your scheduled task?
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#12 » Mon Sep 04, 2017 8:41 am

Yes :
C:\Program Files(x86)\epg123\trace.log
Scheduler:
C:\Program Files(x86)\epg123\epg123.exe -update
C:\Program Files(x86)\epg123\epg123Client.exe -i "C:\Program Files(x86)\epg123\epg123.mxf" -match

Task ran again at 2:00am this morning, return code 0, but epg123.mxf still Sep 02 9:07am.

Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#13 » Mon Sep 04, 2017 2:52 pm

Stanno wrote:Yes :
C:\Program Files(x86)\epg123\trace.log
Scheduler:
C:\Program Files(x86)\epg123\epg123.exe -update
C:\Program Files(x86)\epg123\epg123Client.exe -i "C:\Program Files(x86)\epg123\epg123.mxf" -match

Task ran again at 2:00am this morning, return code 0, but epg123.mxf still Sep 02 9:07am.

Brian

I believe there may be some permission problems running epg123 out of the program files folder. Try installing in the default "c:\epg123" folder or somewhere not in a system folder.

Another option may be to change the user or group of the task to your user account and storing the password. That should work as well.
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#14 » Mon Sep 04, 2017 5:21 pm

Hi Gary, have re-installed to C:\epg123\ and I'll report back tomorrow. Thanks for all your help and advice.
Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#15 » Tue Sep 05, 2017 1:10 pm

Hi Gary, it's fine now.

Many thanks for your patience and help - another satisfied EPG123 user!

Brian
Stanno
 
Posts: 9
Joined: 1 September 2017

Post#16 » Tue Sep 05, 2017 2:34 pm

Awesome. Sorry it took so long to get it resolved.
User avatar
garyan2
 
Posts: 2247
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net


Return to EPG123



Who is online

Users browsing this forum: No registered users and 1 guest

cron