Page 1 of 2

Transferred series does not record

PostPosted: Sun Aug 20, 2017 8:14 pm
by amarkowi
I’m new to EPG123, and setup a new install of 7MC for testing. The install went well (v1.1.3, upgraded to v1.1.15), and I have 21 days of guide data. Awesome product. Thank You!

From the guide, if I do a Record Series, the episodes show up in Recorded TV | View Scheduled, and record as you would expect.

I brought over the latest recordings file from my main 7MC PC (from the ehome\mcepg2-0\backup\recordings folder) and appended *.mxf to the filename.

In the Transfer tool, I opened the mxf file, and transferred one of the green colored series to WMC.

The transferred entry shows up in Recorded TV | View Scheduled | Series, and when I go to the guide entry for an episode, I see the option to Cancel Series. However, none of the episodes show up in Recorded TV | View Scheduled, and the episodes do not record. I’ve tried with several series, all with the same result.

The only quirk to the install, was that I had Windows Search turned off during WMC setup, which I believe I have resolved by running
%SystemRoot%\ehome\ehPrivJob.exe /DoRegisterSearch
and
%SystemRoot%\ehome\ehPrivJob.exe /DoReindexSearchRoot

Any ideas would be greatly appreciated. I have close to 100 series to migrate.

Re: Transferred series does not record

PostPosted: Mon Aug 21, 2017 2:05 am
by garyan2
Which series is this not working on and I'll take a look at the database.

You may have to run the PvrScheduleTask or manually run the "C:\Windows\ehome\mcupdate.exe -PvrSchedule" for the recordings to get scheduled, but it is usually immediate. Are your series recordings set New & Rerun? Check the series recording settings for the Channels setting ... try changing the channel to 'Any channel', save, and then change it to what you want and save.

EDIT: ... and of course, theTVDB API is crawling. Extremely slow right now.

Re: Transferred series does not record

PostPosted: Mon Aug 21, 2017 4:51 pm
by amarkowi
I transferred all 43 of the green series. Running PvrScheduleTask got things going.

The following have episodes listed in Recorded TV | View Scheduled, on the on the rovi pvr but not on the SD pvr:
Marlon - New
Rizzoli & Isles - New and rerun
Hooten and the Lady - New & rerun
The SD lineup is OTA, zip 19038.

I'd like to proceed by resolving as much as possible on the test pvr. Then, after migrating the main pvr to EPG123, importing the recordings from the test pvr. i.e. bringing over the recordings file from the ehome\mcepg2-0\backup\recordings folder on the test pvr, and importing it. Do you see any problems?

Also, a useful addition to the Transfer tool would be the ability to export the left and right series lists to text or csv files. It would make keeping track of the migration project easier.

Re: Transferred series does not record

PostPosted: Tue Aug 22, 2017 12:24 am
by garyan2
amarkowi wrote:I transferred all 43 of the green series. Running PvrScheduleTask got things going.

The following have episodes listed in Recorded TV | View Scheduled, on the on the rovi pvr but not on the SD pvr:
Marlon - New
Rizzoli & Isles - New and rerun
Hooten and the Lady - New & rerun
The SD lineup is OTA, zip 19038.

I'd like to proceed by resolving as much as possible on the test pvr. Then, after migrating the main pvr to EPG123, importing the recordings from the test pvr. i.e. bringing over the recordings file from the ehome\mcepg2-0\backup\recordings folder on the test pvr, and importing it. Do you see any problems?

Also, a useful addition to the Transfer tool would be the ability to export the left and right series lists to text or csv files. It would make keeping track of the migration project easier.

Okay, I'll check these out on a virtual machine here. I did have a similar problem when testing everything out with a couple series. One specific series that wouldn't record was The Big Bang Theory. Everything was correct for the series, it would show all the episodes for that series to record, but not schedule any episodes... no matter what I did. I eventually attributed it to either the VM I was using had seen too many series imports and cancellations, or a quirk in WMC preventing it from working.

With your data points above, I should be able to isolate a bit further.

Re: Transferred series does not record

PostPosted: Tue Aug 22, 2017 1:00 am
by garyan2
Okay, here is what I did and my results...

Created series recordings for Marlon, Rizzoli & Isles, and Hooten and the Lady with a Rovi setup.
Converted to EPG123 guide.
Used the conversion utility to transfer the series to EPG123 and import.
Re-Imported the latest epg123.mxf file. (I'll explain)
-> Originally no episodes for any series set to record. :thumbdown:
Changed Rizzoli & Isles from New & Rerun to New, Save, change back to New & Rerun, Save ... Rizzoli & Isles episodes are now scheduled. :thumbup:
Did the same thing for Marlon ... episodes are now scheduled. :thumbup:
I left Hooten alone, closed WMC, and waited a bit. Not too long, I just waited for the indexing to complete from the above import of the .mxf file.
Opened WMC and Hooten now has episodes scheduled to record. :thumbup:

So my results were positive. The conversion values were correct and the import works. The reason I imported the latest .mxf file was for 2 things, the import from the conversion tool brings with it the Rovi series title and descriptions ... to restore the EPG123 title and descriptions I just import the epg123.mxf file again. This also has the benefit of kicking off the indexing tasks which may be needed.

Next step... there may be differences in how I initially setup my Rovi recordings and you did yours. If you could send me your backup recordings file that you used for the conversion, I can test that out here. See if there is a difference.

Re: Transferred series does not record

PostPosted: Tue Aug 22, 2017 2:56 am
by amarkowi
Sure

Thanks for looking into this.

Re: Transferred series does not record

PostPosted: Tue Aug 22, 2017 4:20 am
by garyan2
amarkowi wrote:Sure

Thanks for looking into this.

Okay, using your lineup (must be nice having 90+ OTA channels) and your recording .mxf file, I used the conversion tool and imported your recordings. After forcing the PvrScheduleTask (mcupdate -PvrSchedule) all 3 of them scheduled episodes to record. I didn't do any other kind of manipulation. This was right after completing a clean start EPG123 install/setup. Can't yet explain why yours are not showing up.

You could try something real quick on your test machine. Use the EPG123 Client and perform a database rebuild ([Rebuild WMC Database] button). Import your epg123.mxf file and force a PvrScheduleTask. See if that brings them back to life. During all this, I realize I should perform that task automatically with the tool. It really doesn't take long at all. Next update.

You may also try to rebuild the index using Control Panel/Indexing Options/Advanced/Rebuild. This will probably take a while.

Re: Transferred series does not record

PostPosted: Tue Aug 22, 2017 6:24 pm
by amarkowi
garyan2 wrote:there may be differences in how I initially setup my Rovi recordings and you did yours


I found something. If I go into the guide entry for any of the problem series, I see the option to Cancel Series. Still within the guide entry, if I go to Series Info | Series Settings, I see Frequency: Record single show, and Show Type:Live. If I Cancel Series, then Record Series, the episodes show up under Recorded TV | View Scheduled. If I try to change Frequency: Record single show, to Record Series, without first cancelling the series, Media Center crashes.

When scheduling the first episode of a new series, we will often record only the first episode. After watching it, if we like it, we will record the series (from the episode entry in Recorded TV). Somehow, the single recorded episode, having been turned into a recorded series seems to be causing a problem.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 3:14 am
by CMQBartzman
I have the exact same problem with my transferred recordings. If I visit the premiere of a show that was scheduled in Rovi in the next two or three weeks (like Scorpion on 9/25), the info says "Cancel Series" or "Record" but nothing shows up in the schedule. If I "Cancel Series" and then "Record Series" it works but that defeats the purpose of transferring the schedules. I have tried mcupdate -PvrSchedule, I have run the PvrScheduleTask and rebuilt the index as suggested and the transferred recordings do not show up in the scheduled recordings list or have the three red circles on the guide. The transfer tool shows all of the scheduled shows in green on the right hand side.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 4:02 am
by garyan2
CMQBartzman wrote:I have the exact same problem with my transferred recordings. If I visit the premiere of a show that was scheduled in Rovi in the next two or three weeks (like Scorpion on 9/25), the info says "Cancel Series" or "Record" but nothing shows up in the schedule. If I "Cancel Series" and then "Record Series" it works but that defeats the purpose of transferring the schedules. I have tried mcupdate -PvrSchedule, I have run the PvrScheduleTask and rebuilt the index as suggested and the transferred recordings do not show up in the scheduled recordings list or have the three red circles on the guide. The transfer tool shows all of the scheduled shows in green on the right hand side.

Is it all series, or just the one that you know of? I haven't found any rhyme or reason yet to why some series will not schedule recordings. I used the recordings file from amarkowi above on a virtual machine here without any issue, but I myself had the same problem on a completely different series. There has been no pattern of what works and what doesn't ... a failing schedule and a working schedule look exactly the same.

I have modified the code for the transfer tool a little for the next release but not expecting it to help with this if you want to give it a shot. The change will be importing the series requests directly into the database instead of using the loadmxf.exe tool to do so. It will also kick-off the PvrSchedule task automatically after import.

Could you send me your recordings file? The more data points I have, the better.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 4:52 am
by CMQBartzman
I can't say if it is all series but all of the ones I scheduled on Rovi that have a premiere coming up in the guide do not re-schedule themselves (The Good Place, Gotham, The Big Bang Theory, Scorpion, NOVA, maybe some others). Some of those I already cancelled and rescheduled since I thought it might have been a fluke. I will try out the new transfer tool although I'm not sure I have my old schedule file anymore since it seemed to work (all green) when I first transferred the recordings almost a month ago.

I would be happy to send you my recordings file if you could tell me where to find it :)

Chris

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 5:07 am
by garyan2
Well, that doesn't make any sense that it would be all of them. :think:

When you performed a Step 1 Clean Start, epg123 created a zip file in the [epg123]\backup folder; backups_yyyyMMdd_hhmmss.zip. In the zip is a file named recordings.mxf which contains all your recording requests. Your oldest zip file will be your Rovi recordings.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 5:36 am
by CMQBartzman
Well, maybe that is the problem. I remember when I first installed epg123 I did do a Clean Start but it didn't seem to do anything. I then reinstalled and tried again and something different happened, like it was working properly. This explanation sucks I know but I just know I had some problems. I have a epg123\backup folder but the only things in it are config_xxx directories, no backups_xxx and no recordings.mxf. I pulled the old recording file for the transfer initially from eHome\mcepg2-2\backup\recordings, the latest file date stamp.

So, it sounds like there were some problems from the start but the series DID show up in the transfer tool on the left and I was able, with some manual intervention from theTVDB, to transfer them to the right and they are green.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 5:57 am
by garyan2
Is the mcepg2-2\backup\recordings folder still there? If so, then you never completed Step 1 which deletes all contents of the eHome folder.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 6:10 am
by CMQBartzman
That mcepg2-2 folder is still there with updated recording files as well as the folders mcepg2-0 and -1. Like I said, I followed the guide and did step 1 but nothing seemed to happen. I did locate my original recordings file before I started the initial transfer so would you suggest I just uninstall epg123 and restart from scratch (ugh)? I could then use the transfer tool on the old recordings file and start anew, right? Not sure what happened but I know I was scratching my head when I first installed because I did not have the files in the \backup folder you the guide stated I should have.

Chris

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 6:25 am
by garyan2
Starting over is certainly a possibility I would recommend. It is totally up to you. If you open the client GUI, pull down the lineup combo box and see more lineups than just "EPG123 Lineups with Schedules Direct," then Rovi still resides in the guide and I would definitely recommend starting over. If not, then the choice is yours.

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 6:34 am
by CMQBartzman
The Lineup pulldown has about a dozen entries in addition to "EPG123 Lineups with Schedules Direct" so starting over it is. Thank you for your patience and help. If I have problems executing step 1 again I will post a followup. Bizarre!

Chris

Re: Transferred series does not record

PostPosted: Thu Sep 07, 2017 2:32 pm
by garyan2
CMQBartzman wrote:The Lineup pulldown has about a dozen entries in addition to "EPG123 Lineups with Schedules Direct" so starting over it is. Thank you for your patience and help. If I have problems executing step 1 again I will post a followup. Bizarre!

Chris

I suspect the reason why the series recordings didn't work was because you were still using Rovi data. You reversed the problem in trying to use Gracenote IDs with a Rovi guide.

Re: Transferred series does not record

PostPosted: Fri Sep 08, 2017 6:23 pm
by CMQBartzman
I am starting the process of reinstalling right now but I noticed why this did not work before for me. When I clicked Clean Start on my Windows 7 machine, I got the UAC popup about the program wanted to change my computer, etc. I hit yes to allow and then I was back at the epgClient screen and nothing seemed to have happened. This is what I experienced the first time I tried to do this a month ago. Once I hit Clean Start AGAIN, I got the popup about erasing eHome. Agreeing to that popup presented me with the popup saying it will start WMC among other things -- basically Step 2. When I did this a month ago, I had to manually start Step 2.

Chris

Re: Transferred series does not record

PostPosted: Fri Sep 08, 2017 7:09 pm
by CMQBartzman
I finished the reinstall which wasn't too bad since a lot of the settings were remembered. After using the transfer tool, the old, transferred series with upcoming new episodes are scheduled as expected. Thanks again for your help. Great program!

Chris