Broke something: now WMC says "no data available"

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Broke something: now WMC says "no data available"

Post#1 » Sat Jul 22, 2017 4:04 pm

I installed EPG on Win7 last week and it on was working. Guide was populated and WMC made recordings. Things were good.

Some channels were missing in Guide (but were shown in the client guide tool listings). Before using EPG, sometines I could get WMC to recognize the channels it was missing by running "scan for more channels". So I tried that again , but post EPG scan for more channels didn't do anything, so I reran the the WMC settings>TVsignal?setupTVsignal. Now the guide says no data available.
I tried WMC settings>Guide>GetLatestGuideListings, it said it got the listings but the problem persisted. I also did a manual import, no change

It looks to me that EPG has provided the info. I tried looking at the epg123.mxf file in an editor to see dates of the programs, but couldn't find any. So I am not sure if the listings have entries for today and the future.

Any suggestions?

===
==== from media center, on 7/22/2017
===
Guide End Date: Guide listings are not available.
EPG123 Lineups with Schedules Direct
ID:42
TV Signal: Digital Cable (ClearQAM)/FM Radio
Language: English
End Date: 8/2/2017 9:00:00 PM
EPG123
Electronic Program Guide in 1-2-3 v1.1.10

===
==== checking file dates
===
C:\Program Files\epg123\epg123.xmf 7/22/2017 8:00 AM
C:\ProgramData\Microsoft\eHome\mcepg2-0.db 7/22/2017 8:39 AM
drewp
 
Posts: 3
Joined: 22 July 2017

Post#2 » Sat Jul 22, 2017 10:29 pm

drewp wrote:I installed EPG on Win7 last week and it on was working. Guide was populated and WMC made recordings. Things were good.

Some channels were missing in Guide (but were shown in the client guide tool listings). Before using EPG, sometines I could get WMC to recognize the channels it was missing by running "scan for more channels". So I tried that again , but post EPG scan for more channels didn't do anything, so I reran the the WMC settings>TVsignal?setupTVsignal. Now the guide says no data available.
I tried WMC settings>Guide>GetLatestGuideListings, it said it got the listings but the problem persisted. I also did a manual import, no change

It looks to me that EPG has provided the info. I tried looking at the epg123.mxf file in an editor to see dates of the programs, but couldn't find any. So I am not sure if the listings have entries for today and the future.

Any suggestions?

Things get interesting with QAM, and I've never had to deal with it myself, but I believe you will have to manually match (subscribe) the lineup station with the tuner channel. That is, unless SD knows what the QAM channels are to perform a match with.

For missing tuner channels, your scan for more channels should work except when the channel has been "deleted". If the missing channel still doesn't show after a scan, click the delete all channels button and then scan again. There shouldn't be a need to perform the TV setup again.

For the "Get Latest Guide Listings" ... doesn't do anything for the guide. That button is for the MS/Rovi guide and since we declined the ToS, there is nothing for WMC to get so it always succeeds.

So at this point, perform an automatch, if you can, in the client gui or a manual match (subscribe) if you can't.
User avatar
garyan2
 
Posts: 2158
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#3 » Sat Jul 22, 2017 10:53 pm

garyan2 wrote:
For the "Get Latest Guide Listings" ... doesn't do anything for the guide. That button is for the MS/Rovi guide and since we declined the ToS, there is nothing for WMC to get so it always succeeds.



I wonder if this could be made to work. I'm assuming that button makes WMC call mcupdate with some set of arguments.

If mcupdate was renamed and then replaced with an mcupdate interposer program the interposer could check the arguments and then either invoke epg123 if
the args are asking for a guide update otherwise it could invoke the original mcupdate with the given args. (so other mcupdate invocations would still work properly).

Just a thought.
stuartm
 
Posts: 310
Joined: 5 November 2012
Location: Longmont, CO
HTPC Specs: Show details

Post#4 » Fri Jul 28, 2017 1:18 am

garyan2 wrote:
drewp wrote:I installed EPG on Win7 last week and it on was working. Guide was populated and WMC made recordings. Things were good.

Some channels were missing in Guide (but were shown in the client guide tool listings). Before using EPG, sometines I could get WMC to recognize the channels it was missing by running "scan for more channels". So I tried that again , but post EPG scan for more channels didn't do anything, so I reran the the WMC settings>TVsignal?setupTVsignal. Now the guide says no data available.
I tried WMC settings>Guide>GetLatestGuideListings, it said it got the listings but the problem persisted. I also did a manual import, no change

It looks to me that EPG has provided the info. I tried looking at the epg123.mxf file in an editor to see dates of the programs, but couldn't find any. So I am not sure if the listings have entries for today and the future.

Any suggestions?

Things get interesting with QAM, and I've never had to deal with it myself, but I believe you will have to manually match (subscribe) the lineup station with the tuner channel. That is, unless SD knows what the QAM channels are to perform a match with.

For missing tuner channels, your scan for more channels should work except when the channel has been "deleted". If the missing channel still doesn't show after a scan, click the delete all channels button and then scan again. There shouldn't be a need to perform the TV setup again.

For the "Get Latest Guide Listings" ... doesn't do anything for the guide. That button is for the MS/Rovi guide and since we declined the ToS, there is nothing for WMC to get so it always succeeds.

So at this point, perform an automatch, if you can, in the client gui or a manual match (subscribe) if you can't.


Instead of trying to understand the problem and debugging, I started over again and carefully followed the directions.
Things are working again.

WMC still fails to detect some channels that exist. I ran WinTV and it happily found the channels that WMC couldn't.
I will try to get suggestions for this by posting to the general Win7 WMC forum.

Thanx for the help
drewp
 
Posts: 3
Joined: 22 July 2017


Return to EPG123



Who is online

Users browsing this forum: No registered users and 1 guest

cron