Lineup Services in client is blank

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Lineup Services in client is blank

Post#1 » Sat Jul 08, 2017 3:50 pm

Hi guys,

running into an issue in setting up EPG123 for the firs time, in that in the client, my service lineup is blank, as if its not getting the lineup from SD. I am running 1.1.10 EPG123 on a Win8.1 machine. I confirmed my login to SD twice and have followed the steps outlined in the PDF a few different times and the results are the same.

Attached are screenshots and my trace log - I am at a road block unfortunately until I can get this resolved (no way of mapping channels) - any ideas or thoughts? something I am missing?

epg123 1.png


epg123 2.png


Code: Select all
[7/7/2017 6:25:38 PM] ===============================================================================
[7/7/2017 6:25:38 PM]  Activating the epg123 client GUI. version 1.1.10 for Win8.1
[7/7/2017 6:25:38 PM] ===============================================================================
[7/7/2017 6:25:39 PM] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[7/7/2017 6:25:45 PM] [ERROR] Backup lineup file does not exist.
[7/7/2017 6:25:45 PM] [ERROR] Backup recordings file does not exist.
[7/7/2017 6:25:45 PM] [ERROR] Backup subscriptions file does not exist.
[7/7/2017 6:25:45 PM] [ERROR] Service ehrec was not found on computer '.'.
[7/7/2017 6:30:52 PM] ===============================================================================
[7/7/2017 6:30:53 PM]  Activating the epg123 configuration GUI.
[7/7/2017 6:30:53 PM] ===============================================================================
[7/7/2017 6:30:54 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:30:54 PM] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[7/7/2017 6:31:00 PM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/7/2017 6:31:01 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:31:01 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:31:01 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/7/2017 6:31:01 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/7/2017 6:31:04 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/7/2017 6:31:06 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/7/2017 6:31:06 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/7/2017 6:31:43 PM] [ INFO] Successfully created the daily update task in Task Scheduler for 01:30.
[7/7/2017 6:31:43 PM] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00000001
[7/7/2017 6:31:47 PM] ===============================================================================
[7/7/2017 6:31:47 PM]  Beginning epg123 update execution.
[7/7/2017 6:31:47 PM] ===============================================================================
[7/7/2017 6:31:47 PM] [ INFO] Beginning EPG123 update execution. 2017-07-08 00:31:47Z
[7/7/2017 6:31:47 PM] [ INFO] DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: False , LogoOverride: True , AutoAddNew: False
[7/7/2017 6:31:47 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:31:47 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:31:47 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:31:48 PM] [ INFO] Successfully retrieved TMDb configurations.
[7/7/2017 6:31:48 PM] [ INFO] epg123 update execution time was 00:00:00.5000196.
[7/7/2017 6:31:48 PM] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00000001
[7/7/2017 6:33:07 PM] [ERROR] Service ehrec was not found on computer '.'.
[7/7/2017 6:33:33 PM] [ INFO]
Successfully imported latest lineup file into database.
[7/7/2017 6:33:33 PM] [ INFO]
Successfully imported latest subscriptions file into database.
[7/7/2017 6:33:33 PM] [ INFO]
Successfully imported latest recordings file into database.
[7/7/2017 6:33:33 PM] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00000001
[7/7/2017 6:35:14 PM] ===============================================================================
[7/7/2017 6:35:14 PM]  Activating the epg123 configuration GUI.
[7/7/2017 6:35:14 PM] ===============================================================================
[7/7/2017 6:35:15 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:35:15 PM] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00000001
[7/7/2017 6:35:15 PM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/7/2017 6:35:16 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:35:16 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:35:16 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/7/2017 6:35:16 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/7/2017 6:35:41 PM] ===============================================================================
[7/7/2017 6:35:41 PM]  Beginning epg123 update execution.
[7/7/2017 6:35:41 PM] ===============================================================================
[7/7/2017 6:35:41 PM] [ INFO] Beginning EPG123 update execution. 2017-07-08 00:35:41Z
[7/7/2017 6:35:41 PM] [ INFO] DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: False , LogoOverride: True , AutoAddNew: False
[7/7/2017 6:35:41 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:35:41 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:35:41 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:35:42 PM] [ INFO] Successfully retrieved TMDb configurations.
[7/7/2017 6:35:42 PM] [ INFO] epg123 update execution time was 00:00:00.5000219.
[7/7/2017 6:36:41 PM] ===============================================================================
[7/7/2017 6:36:41 PM]  Activating the epg123 configuration GUI.
[7/7/2017 6:36:41 PM] ===============================================================================
[7/7/2017 6:36:42 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:36:42 PM] [ INFO] Successfully queried the Task Scheduler for status. Ready.The task has not yet run. Exit: 0x00000001
[7/7/2017 6:36:43 PM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/7/2017 6:36:43 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:36:43 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:36:43 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/7/2017 6:36:43 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/7/2017 6:36:45 PM] ===============================================================================
[7/7/2017 6:36:45 PM]  Beginning epg123 update execution.
[7/7/2017 6:36:45 PM] ===============================================================================
[7/7/2017 6:36:45 PM] [ INFO] Beginning EPG123 update execution. 2017-07-08 00:36:45Z
[7/7/2017 6:36:45 PM] [ INFO] DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: False , LogoOverride: True , AutoAddNew: False
[7/7/2017 6:36:45 PM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-07T20:19:29Z
[7/7/2017 6:36:45 PM] [ INFO] system status: Online , message: No known issues.
[7/7/2017 6:36:46 PM] [ INFO] epg123 is up to date. version: 1.1.10
[7/7/2017 6:36:46 PM] [ INFO] Successfully retrieved TMDb configurations.
[7/7/2017 6:36:46 PM] [ INFO] epg123 update execution time was 00:00:00.6093985.
[7/8/2017 1:30:00 AM] ===============================================================================
[7/8/2017 1:30:00 AM]  Beginning epg123 update execution.
[7/8/2017 1:30:00 AM] ===============================================================================
[7/8/2017 1:30:00 AM] [ INFO] Beginning EPG123 update execution. 2017-07-08 07:30:00Z
[7/8/2017 1:30:00 AM] [ INFO] DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: False , LogoOverride: True , AutoAddNew: False
[7/8/2017 1:30:01 AM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/8/2017 1:30:02 AM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-08T02:55:34Z
[7/8/2017 1:30:02 AM] [ INFO] system status: Online , message: No known issues.
[7/8/2017 1:30:02 AM] [ INFO] epg123 is up to date. version: 1.1.10
[7/8/2017 1:30:02 AM] [ INFO] Successfully retrieved TMDb configurations.
[7/8/2017 1:30:02 AM] [ERROR] Unhandled exception caught from main program. message: There is an error in XML document (0, 0).
[7/8/2017 1:30:03 AM] [ERROR] File "epg123.mxf" does not exist.
[7/8/2017 9:35:12 AM] ===============================================================================
[7/8/2017 9:35:12 AM]  Activating the epg123 configuration GUI.
[7/8/2017 9:35:12 AM] ===============================================================================
[7/8/2017 9:35:13 AM] [ INFO] epg123 is up to date. version: 1.1.10
[7/8/2017 9:35:13 AM] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 7/8/2017 1:30:03 AM; Exit: 0xFFFFFFFF
[7/8/2017 9:35:14 AM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/8/2017 9:35:14 AM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-08T15:17:57Z
[7/8/2017 9:35:14 AM] [ INFO] system status: Online , message: No known issues.
[7/8/2017 9:35:14 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/8/2017 9:35:14 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/8/2017 9:36:09 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/8/2017 9:36:16 AM] [ERROR] Cannot perform runtime binding on a null reference
[7/8/2017 9:36:16 AM] [ERROR] SD API WebException Thrown. Message: The remote server returned an error: (400) Bad Request. , Status: ProtocolError
[7/8/2017 9:36:16 AM] [ERROR] SD responded with error code: 4102 , message: No lineups have been added to this account. , serverID: 20141201.web.1 , datetime: 2017-07-08T15:36:18Z
[7/8/2017 9:36:16 AM] [ERROR] Did not receive a response from Schedules Direct for a client lineup listings.
[7/8/2017 9:36:20 AM] [ERROR] SD API WebException Thrown. Message: The remote server returned an error: (400) Bad Request. , Status: ProtocolError
[7/8/2017 9:36:20 AM] [ERROR] SD responded with error code: 4102 , message: No lineups have been added to this account. , serverID: 20141201.web.1 , datetime: 2017-07-08T15:36:21Z
[7/8/2017 9:36:20 AM] [ERROR] Did not receive a response from Schedules Direct for a client lineup listings.
[7/8/2017 9:36:21 AM] [ INFO] Successfully retrieved list of available countries from Schedules Direct.
[7/8/2017 9:36:26 AM] [ INFO] Successfully retrieved the headends for USA and postal code 84405.
[7/8/2017 9:36:41 AM] [ INFO] Successfully added lineup USA-UT43414-X to account. serverID: 20141201.web.1 , message: Added lineup. , changesRemaining: 5
[7/8/2017 9:36:41 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/8/2017 9:36:41 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-UT43414-X.
[7/8/2017 9:36:51 AM] ===============================================================================
[7/8/2017 9:36:51 AM]  Activating the epg123 client GUI. version 1.1.10 for Win8.1
[7/8/2017 9:36:51 AM] ===============================================================================
[7/8/2017 9:36:52 AM] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 7/8/2017 1:30:03 AM; Exit: 0xFFFFFFFF
[7/8/2017 9:36:58 AM] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 7/8/2017 1:30:03 AM; Exit: 0xFFFFFFFF
[7/8/2017 9:37:15 AM] ===============================================================================
[7/8/2017 9:37:15 AM]  Beginning epg123 update execution.
[7/8/2017 9:37:15 AM] ===============================================================================
[7/8/2017 9:37:15 AM] [ INFO] Beginning EPG123 update execution. 2017-07-08 15:37:15Z
[7/8/2017 9:37:15 AM] [ INFO] DaysToDownload: 14 , PrefixEpisodeTitle: False , AppendEpisodeDesc: True , TMDbCoverArt: False , LogoOverride: True , AutoAddNew: True
[7/8/2017 9:37:15 AM] [ INFO] Status request successful. account expires: 2017-07-14T23:14:06Z , lineups: 1/4 , lastDataUpdate: 2017-07-08T15:17:57Z
[7/8/2017 9:37:15 AM] [ INFO] system status: Online , message: No known issues.
[7/8/2017 9:37:15 AM] [ INFO] epg123 is up to date. version: 1.1.10
[7/8/2017 9:37:15 AM] [ INFO] Successfully retrieved TMDb configurations.
[7/8/2017 9:37:15 AM] [ INFO] epg123 update execution time was 00:00:00.4484048.
[7/8/2017 9:37:29 AM] ===============================================================================
[7/8/2017 9:37:29 AM]  Activating the epg123 client GUI. version 1.1.10 for Win8.1
[7/8/2017 9:37:29 AM] ===============================================================================
[7/8/2017 9:37:30 AM] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 7/8/2017 1:30:03 AM; Exit: 0xFFFFFFFF
JDP
 
Posts: 7
Joined: 8 July 2017

Post#2 » Sat Jul 08, 2017 9:03 pm

Forgot to add that my source is an HAD Homerun Prime, with 3 tuners connected to Comcast via a cable card.
JDP
 
Posts: 7
Joined: 8 July 2017

Post#3 » Sun Jul 09, 2017 4:32 pm

another update - I reverted back to Rovi to see if the outage I was seeing was over, it wasnt. I left it like that for a day and decided to take another look at EPG123 - lo and behold the client was showing the SD data on the right panel as I was expecting it would. Bad news, I reset everything; deleted ehome again, re-added line up in server, went through the TV setup turning off Rovi, chose execute and let it rip; went back to the client GUI, and its blank again.

This time I thought maybe it needed some time to download everything and build the database up (as I was seeing 80% RAM usage on the machine while it looked idle and normally it sites at 20% ish) so I let it sit over night, come back in the AM, RAM usage is back to normal, but client lineup (right side) is still blank, nothing in the drop down, or anything like that.

Something is going wrong in the hand off from the server to the client GUI and the log isn't telling me much, this morning I tried running the execute again, I see the progress bars flash up, and then disappear, same results (the progress bar never stays up for very long and I don't see much of it no matter if its a fresh run or a rerun later). I have even tried an uninstall and reinstall with the same results - perhaps its some permissions issue somewhere? I am always launching both the client and server as admin to try and avoid that, but who knows....

I even let it run at its scheduled time as per my task, and no change either. exit code: 0xFFFFFFFF

Willing to have a remote session via WebEx, Teamviewer, or Zoom (I have access to all 3) if anyone wants to take a look, or if anyone has any idea of what I could try to get this working, as right now my WMC is pretty much a brick (only use it for TV and very light DVR services)
JDP
 
Posts: 7
Joined: 8 July 2017

Post#4 » Sun Jul 09, 2017 4:47 pm

Sorry, this post just now showed up for me. I think this might be the same issue brought up yesterday here. viewtopic.php?f=99&t=11035&p=119246&hilit=settings.xml#p119239

Let me know as soon as you can if this is the issue or not. Thank you.
User avatar
garyan2
 
Posts: 2162
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#5 » Sun Jul 09, 2017 4:51 pm

no worries, I saw that post and missed that you had him downgrade to .8 - doing that now and will report back right away
JDP
 
Posts: 7
Joined: 8 July 2017

Post#6 » Sun Jul 09, 2017 5:03 pm

progress bar is there now with .8 and running as expect (no more flash up and then gone), that seems to be the fix, anything I can check on my end for you? seems like you found the issue in the other thread, but more data/repeatable data is always good, so if I can help, or test anything for you, let me know.
JDP
 
Posts: 7
Joined: 8 July 2017

Post#7 » Sun Jul 09, 2017 5:11 pm

JDP wrote:progress bar is there now with .8 and running as expect (no more flash up and then gone), that seems to be the fix, anything I can check on my end for you? seems like you found the issue in the other thread, but more data/repeatable data is always good, so if I can help, or test anything for you, let me know.

No need. I think I've sufficient evidence to say the root cause has correctly been identified and the corrective action addresses it. Like I posted in the other thread, you can delete the empty C:\ProgramData\MyChannelLogos\settings.xml file and put v1.1.10 back on.

I should also note, when you go back to v1.1.10, I recommend deleting all the logos in the epg123\logos folder. In version 1.1.8 the default logo size was 225x75 whereas v1.1.10 the default is 144x64. The big logos will only be used if MCLXL is installed and big logos are enable. If you are not going to use the big logos option, the 144x64 logos look better in the guide than the 225x75.
User avatar
garyan2
 
Posts: 2162
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#8 » Sun Jul 09, 2017 5:14 pm

Perfect, thanks. Its still building out the guide now. and good note on the logos, I am not using MCLXL at all so i'll clear out the space and have it go to the better looking variants
JDP
 
Posts: 7
Joined: 8 July 2017

Post#9 » Sun Jul 09, 2017 5:24 pm

FYI, guide is back and better than ever- thanks for all the help! sorry I missed the fix in the other thread, read over it to fast :/ typically user right?
JDP
 
Posts: 7
Joined: 8 July 2017

Post#10 » Wed Jul 12, 2017 8:30 pm

I just wanted to say thank you - I was having an issue after installing EPG123 and couldn't figure out what was going wrong, it turns out I just had to delete C:\ProgramData\MyChannelLogos\settings.xml and the setup works as intended. Now if I can only figure out how to get all of my big logs back, it seems some are smaller than then used to be.

Great guide/program!
Deckard15
 
Posts: 4
Joined: 27 December 2014


Return to EPG123



Who is online

Users browsing this forum: bcswa and 2 guests

cron