Page 1 of 2

After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 5:41 am
by dazz553
It seems that after following the instructions (including "Clean start") that I am magically supposed to see the guide data in WMC. Instead, I see what I've seen ever since the "Clean start" step, which is "live tv setup". I tried "Rebuild WMC Database" a couple times. Although in the epg123 client there are no listings, which seems wrong. The server shows listings.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 5:48 am
by garyan2
I think you may have missed a couple things.

"live tv setup": this will go away once you close WMC and import the guide data.

Not having any listing in the client will support the above in that the mxf file has not been imported. In the client, click the [Manual Import] button, select the epg123.mxf file and wait for import to complete. When it is done and you have listings on the right side, click the Automatch by: [# Number] button to link the listings to the guide channels.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 1:40 pm
by dazz553
In the client I see the lineup / channels in the right pane "Lineup Services". I see nothing in the left pane "Guide Channels". If I click "Number" or "Call Sign" for "Automatch by" nothing happens. "Manual Import" is grayed out.

I clicked "Rebuild WMC Database" and that restarted the client. Then I checked the Automatch box and clicked "Rebuild WMC Database". To that it responds "Failed to delete the database file." I'll try in Safe Mode.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 1:53 pm
by dazz553
After going into Safe Mode, clicking on Rebuild... successfully deleted the existing db. Then I rebooted and clicked Rebuild... again which restarted it, then Rebuild... again which showed all the channels in the right pane. Manual Import is still grayed out. And there left Guide Channels pane is still empty. How do I fill that pane with the channels?

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:09 pm
by dazz553
Since I am not able to import the channels using the client, I thought I'd try using the server. I set the scheduled task to auto import and auto match, and set the time to 2 minutes from "now". But that time is past and it only says "Ready. The task did not run yet. Exit 0x000000001" :thumbdown:

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:17 pm
by dazz553
I tried again, this time clicking "Save" then "Exit" in the server before the scheduled time. After the time passed I tried to open the server a couple times but it would not. I tried the client and it showed the attempt at the time I had set in the server, and it showed a specific error code. I then was able to start the server and it shows error code 0xFFFFFFFF. Now the client also shows 0xFFFFFFFF.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:18 pm
by dazz553
Tried again; the client shows error code 0x00041301

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:32 pm
by garyan2
You've missed a bigger step than I thought, sorry. If you have nothing in the left pane, that means that you have not set up your tuners (TV Setup).

Note: A database rebuild will only work if have something to rebuild. Step 1 wipes out all the backups that are used for a rebuild so a rebuild at this point will have zero results.

Since you have done Step 1, you must do Step 2 and then Step 3.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:35 pm
by garyan2
IMPORTANT: I should also mention, to be on the safe side, start over with Step 1 and follow the guide 'til the end. If guide listings are imported into the database before the tuners are setup, it is forever corrupted and you will have to start at Step 1 again.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:41 pm
by dazz553
Here are the latest log entries

Code: Select all
[7/6/2017 7:18:00 AM] ===============================================================================
[7/6/2017 7:18:00 AM]  Beginning epg123 update execution.
[7/6/2017 7:18:00 AM] ===============================================================================
[7/6/2017 7:18:00 AM] [ INFO] Beginning EPG123 update execution. 2017-07-06 14:18:00Z
[7/6/2017 7:18:00 AM] [ INFO] DaysToDownload: 21 , PrefixEpisodeTitle: True , AppendEpisodeDesc: False , TMDbCoverArt: True , LogoOverride: True , AutoAddNew: False
[7/6/2017 7:18:01 AM] [ INFO] Token request successful. serverID: 20141201.web.1
[7/6/2017 7:18:01 AM] [ INFO] Status request successful. account expires: 2017-07-13T04:20:58Z , lineups: 1/4 , lastDataUpdate: 2017-07-06T11:21:17Z
[7/6/2017 7:18:01 AM] [ INFO] system status: Online , message: No known issues.
[7/6/2017 7:18:02 AM] [ INFO] epg123 is up to date. version: 1.1.10
[7/6/2017 7:18:02 AM] [ INFO] Successfully retrieved TMDb configurations.
[7/6/2017 7:18:02 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[7/6/2017 7:18:02 AM] Entering buildLineupServices() for 1 lineups.
[7/6/2017 7:18:02 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-CA04497-X.
[7/6/2017 7:18:04 AM] Exiting buildLineupServices(). SUCCESS.
[7/6/2017 7:18:04 AM] Entering getAllScheduleEntryMd5s() for 21 days on 412 stations.
[7/6/2017 7:18:09 AM] [ INFO] Successfully retrieved Md5s for 412 station's daily schedules.
[7/6/2017 7:18:09 AM] ===============================================================================
[7/6/2017 7:18:09 AM]  Activating the epg123 client GUI. version 1.1.10 for Win7
[7/6/2017 7:18:09 AM] ===============================================================================
[7/6/2017 7:18:10 AM] [ INFO] Found 8652 cached daily schedules.
[7/6/2017 7:18:10 AM] [ INFO] Downloaded 0 daily schedules.
[7/6/2017 7:18:10 AM] [ INFO] Successfully queried the Task Scheduler for status. Running. Last Run 7/6/2017 7:18:00 AM; Exit: 0x00041301
[7/6/2017 7:18:21 AM] [ INFO] Processed 8652 daily schedules for 412 stations.
[7/6/2017 7:18:21 AM] Exiting getAllScheduleEntryMd5s(). SUCCESS.
[7/6/2017 7:18:21 AM] Entering buildAllProgramEntries() for 44720 programs.
[7/6/2017 7:18:45 AM] [ INFO] Found 44720 cached program descriptions.
[7/6/2017 7:18:45 AM] [ INFO] Processed 44720 program descriptions.
[7/6/2017 7:18:45 AM] Exiting buildAllProgramEntries(). SUCCESS.
[7/6/2017 7:18:45 AM] Entering buildAllGenericSeriesInfoDescriptions() for 8515 series.
[7/6/2017 7:18:47 AM] [ INFO] Found 8515 cached series descriptions.
[7/6/2017 7:18:47 AM] [ INFO] Processed 8515 series descriptions.
[7/6/2017 7:18:47 AM] Exiting buildAllGenericSeriesInfoDescriptions(). SUCCESS.
[7/6/2017 7:18:47 AM] Entering getAllMoviePosters() for 4635 movies.
[7/6/2017 7:18:47 AM] [ INFO] Found 4189 cached movie poster links.
[7/6/2017 7:18:48 AM] [ INFO] Successfully retrieved artwork info for 446 programs.
[7/6/2017 7:18:49 AM] [ INFO] TMDb catalog search for "Du bleu jusqu'en Amérique" from 1999 found 0 results.
...
[Many more like that...]
...
[7/6/2017 7:19:55 AM] [ INFO] TMDb catalog search for "Rocambole vs. las Mujeres Arpías" from 1968 found 0 results.
[7/6/2017 7:19:55 AM] [ INFO] Processed 4635 movie poster links.
[7/6/2017 7:19:55 AM] Exiting getAllMoviePosters(). SUCCESS.
[7/6/2017 7:19:55 AM] Entering getAllSeriesImages() for 8515 series.
[7/6/2017 7:19:55 AM] [ INFO] Found 7512 cached series image links.
[7/6/2017 7:19:57 AM] [ INFO] Successfully retrieved artwork info for 500 programs.
[7/6/2017 7:19:59 AM] [ INFO] Successfully retrieved artwork info for 500 programs.
[7/6/2017 7:20:00 AM] [ INFO] Successfully retrieved artwork info for 3 programs.
[7/6/2017 7:20:00 AM] [ INFO] Processed 8515 series image links.
[7/6/2017 7:20:00 AM] Exiting getAllSeriesImages(). SUCCESS.
[7/6/2017 7:20:00 AM] [ INFO] Completed compiling keywords and keyword groups.
[7/6/2017 7:20:00 AM] Entering writeMxf().
[7/6/2017 7:20:05 AM] [ INFO] Completed save of mxf file.
[7/6/2017 7:20:05 AM] Exiting writeMxf(). SUCCESS.
[7/6/2017 7:20:05 AM] Entering writeImageArchive().
[7/6/2017 7:20:05 AM] [ INFO] Completed save of image archive file.
[7/6/2017 7:20:05 AM] Exiting writeImageArchive(). SUCCESS.
[7/6/2017 7:20:08 AM] [ INFO] 0 files deleted from the cache directory during cleanup.
[7/6/2017 7:20:08 AM] [ INFO] Generated .mxf file contains 412 services, 8515 series, 44720 programs, and 62551 people with 13164 image links.
[7/6/2017 7:20:08 AM] [ INFO] Completed EPG123 update execution. SUCCESS.
[7/6/2017 7:20:08 AM] [ INFO] epg123 update execution time was 00:02:07.8754251.
[7/6/2017 7:20:08 AM] ===============================================================================
[7/6/2017 7:20:08 AM]  Beginning epg123 client execution.
[7/6/2017 7:20:08 AM] ===============================================================================
[7/6/2017 7:20:08 AM] [ INFO] Beginning epg123 client execution. 2017-07-06 14:20:08Z
[7/6/2017 7:20:08 AM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False
[7/6/2017 7:20:08 AM] [ INFO] epg123 client version: 1.1.10 for Win7
[7/6/2017 7:20:08 AM] [ERROR] There are no devices/tuners configured in the database store. Perform WMC TV Setup prior to importing guide lisitngs. Aborting Import.
[7/6/2017 7:20:08 AM] [ERROR] Failed to import .mxf file. Exiting.

Since it says " Perform WMC TV Setup prior to importing guide lisitngs." I tried to set up the TV tuners in WMC. (I don't see this mentioned in the EPG123 guide). This has me accept that WMC will try to get guide data which it fails to do. Then a couple steps later it says "TV setup cannot continue -- TV setup has encountered a serious problem. Click Finish to exit and try again. If the problem persists restart WMC or the computer.

My TV setup is hosed since trying to install EPG123.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:46 pm
by dazz553
I can try redoing everything. But which step in the guide says to install the tuners? I don't see that. And how can one go through tuner setup in WMC without agreeing to TOS and agreeing to download guide data (which will undo the "Clean start" step)?

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:49 pm
by garyan2
You and your MC will be fine... but you need to complete Step 2 before trying step 3. Step 2 will setup your tuners in WMC.

If you get the download error in WMC after you say 'No' to the guide terms of service, click the back button and say 'No' again to the terms of service and try again. I've found pretty good success doing this when MS servers are being a pain.

Another option would be to disconnect your network cable, say 'No' to the guide terms of service, reconnect your network cable and wait a few seconds, and then continue. The information it downloads isn't necessary as far as I've seen.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:50 pm
by dazz553
After redoing step 1 (Clean start), I got prompted to set up the TV signal. That did not happen the first time. Let's see how it goes this time... continuing with step 2 which is set up TV tuners...

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:51 pm
by garyan2
dazz553 wrote:And how can one go through tuner setup in WMC without agreeing to TOS and agreeing to download guide data (which will undo the "Clean start" step)?

After declining the TOS, it will only download regional specific tuner information (what kind of broadcast medium ATSC, NTSC, channel frequencies, tuner spacing ...), nothing to do with the guide.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 2:53 pm
by garyan2
Actually, there is a video on my website you can watch me setup my WMC in under 5 1/2 minutes... it's in the 'Install' tab.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 3:19 pm
by dazz553
So after starting over I managed to see the channels in the left Guide Channels pane (but not the right). I then clicked Manual Import and they appeared in the right. But WMC did not show any guide data. So I did [settings]→[TV]→[Guide]→[Get Latest Guide Listings] then [Rebuild WMC Database].

I restarted WMC and it still has an empty guide.

:-(

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 3:30 pm
by garyan2
The listings need to be connected to the tuner channels. Use the client Automatch by number button.

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 3:31 pm
by garyan2
Keep away from the rebuild database button. Did you lose tuner channels after that?

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 3:44 pm
by dazz553
No I did not lose my channels after Rebuild. Nothing changed.

I clicked on Automatch by number and got a .NET Framework error dialog:

Unhandled exception has occurred in a component in your application. If you click continue the application will ignore the error...
Unable to commit the StoredObject of id 1C00000016400 back to the ObjectStore.

I clicked continue. The spinner symbol is there and continues to be for a long time now...

It seems everything that could go wrong is. :-(

Re: After installing, I see "live tv setup"

PostPosted: Thu Jul 06, 2017 3:47 pm
by dazz553
So I closed the client (spinner was still spinning) and reopened it. The channels were checked in the left pane. I tried WMC. Still no guide. Closed it and am trying Manual Import again...