Guide and Schedule Recovery

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Guide and Schedule Recovery

Post#1 » Wed Jun 28, 2017 8:31 pm

I had a strange one tonight. I came to use Media Center and got a pop up that there was a problem with my guide and scheduled recordings. Media Center then ran a recovery which left me with an empty guide and no scheduled recordings.

I checked the EPG123 logs for the previous run and all looked fine, no errors or problems.

So I ran EPG123 manually which repopulated my guide. I then ran the PvrSchedule task which rebuilt my scheduled series recordings. The only thing missing then were any individual recordings I had scheduled.

I am not sure what the root cause was, but at least I was back up and running fairly quickly.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#2 » Wed Jun 28, 2017 8:47 pm

This has happened to me on a few occasions, but it's rare.

I believe that WMC detects a problem and crashes the guide. If you can run automatch then it is easy to fix. If you have customized channels, that has to be re-done.

This happens to me if I start WMC while the "ehtray" service is running (e.g. the green button in the tray).

I don't think this problem can be consistently repeated and there is no current solution.
DaveInPa
 
Posts: 66
Joined: 30 October 2015

Post#3 » Wed Jun 28, 2017 11:12 pm

DaveInPa wrote:If you have customized channels, that has to be re-done.

Not necessarily. When the crash happens, WMC creates a new database and a new folder (mcepgX-X) to start fresh. Since the old stuff is still there, you could theoretically restore the backup\lineups file which will restore any custom channel number and restore the guide listing matches from before.
User avatar
garyan2
 
Posts: 2204
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#4 » Thu Jun 29, 2017 12:21 pm

I guess I should have said that for my situation, I have always had to redo any custom channels. Thankfully, I only have a few. (I merge my OTA channels with the cable channels that are the same.)
DaveInPa
 
Posts: 66
Joined: 30 October 2015

Post#5 » Thu Jun 29, 2017 7:03 pm

This happened to me last week. Had it all patched up in a jiffy. Just ran the import tool and guide tool and got it all back up and going. Took a little bit of time but all is well. I believe this has happened to me in the past too but long ago now. What really sucks is that WMC won't let you do anything until you "recover" into a blank guide. The option to "Cancel" is there but you cannot select it, you can only hit "Okay" and proceed.
Sammy2
 
Posts: 1352
Joined: 24 August 2012
HTPC Specs: Show details

Post#6 » Fri Jun 30, 2017 8:44 pm

Well fingers crossed I never get another. This is the first time for me after running Media Center for several years - since XP.

It would be real pain if it happend whilst I was away. I have MyMediaCenter for remote access but this wouldn't be able to kick off the initial recovery.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#7 » Sat Jul 01, 2017 3:01 pm

I've been running my setup in WMC7 for over 5 years now with no real problems. I absolutely LOVE EPG123 and have been using it since the 1.0.0 release! It's really breathed life back into my system! I run a pretty vanilla setup and use it primarily for OTA DVR'ing. I'm lucky to live in an area that has 80+ (rescanned last week to verify) OTA channels. Granted, only about half are remotely interesting, but they're free...

Anyway... I have this same issue about once a month or so. When it happens I do the same as Sammy2 and it gets patched up with the exception of having to [Add Missing Channels] by following the "Additional OTA Configuration" instructions in the EPG123 installation guide.

Is there any way to backup my channel lineup and restore it after this happens instead of typing in the channels manually? I've looked at Sean's Backup and also noticed that garyan2 posted links to Guide Tool (albeit crippled) on his website.

I'm not really sure about these tools because of my unfamiliarity. I don't need a high level, complex, configuration utility, all I'd like to do is make a backup of my channel lineup (and "Series" if possible) and be able to restore it pretty easily. Insights and recommendations are certainly welcome!
User avatar
StinkyImp
 
Posts: 17
Joined: 11 May 2017
HTPC Specs: Show details

Post#8 » Tue Aug 01, 2017 11:20 pm

I just had another of these. Very strange. I have been running Media Center for years and never had this. Then I get two a month apart.

I guess the old databases and backup folders will just hang around forever. Is it safe to delete them?
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran


Return to EPG123



Who is online

Users browsing this forum: No registered users and 2 guests

cron