2017-06-07: Schedules Direct service issue

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Re: 2017-06-07: Schedules Direct service issue

Post#81 » Fri Jun 16, 2017 6:12 pm

Still 7 days for me. I never lost my line up though.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#82 » Fri Jun 16, 2017 7:17 pm

Latest from Schedules Direct

Re: 2017-06-07: Service disruption
Postby rkulagow » Fri Jun 16, 2017 9:15 am
2017-06-16 @ 1:10P / 16:10 UTC

We have found an issue with some responses from our upstream; stations which are valid aren't returning data and are delaying processing because the null response is different than previous null responses, so our code was in an infinite retry loop. Code has been added to break out of the loop and we have notified our upstream of the stations which are causing the problem.

We will be increasing our upstream fetch quantity later today to restore 14+ days of schedule.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#83 » Sat Jun 17, 2017 10:10 am

Yep, back up to 14 days for me. Which is as good as it gets for my listings.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#84 » Sat Jun 17, 2017 5:04 pm

garyan2 wrote:Looks like we are holding steady at 13 days of data right now. SD is taking measured steps in building everything back up to the 21 days we are used to.

Just did the math for my 5:01 AM EDT (so, circa 21st century Zulu time... OK, 9:01 :P) scheduled update and got 20.9+ days for my configured 21 days. That's for Comcast Digital in my area. Data starts to drop off the evening of July 7, so it's looking good on my end.
Sancho
 
Posts: 91
Joined: 13 June 2012

Post#85 » Sun Jun 18, 2017 12:09 pm

Looks like I'm back to normal, too... Channels all seem to be going out to July 8th with data now! :D
User avatar
Doctor Feelgood
 
Posts: 320
Joined: 16 August 2012
Location: NJ
HTPC Specs: Show details

Post#86 » Mon Jun 19, 2017 2:41 pm

I'm now at 21 days, out to July 10 at 12am so that's all good!
Sammy2
 
Posts: 1352
Joined: 24 August 2012
HTPC Specs: Show details

Post#87 » Fri Jun 23, 2017 2:51 pm

Update from rkulagow on the SD forum.

Re: 2017-06-07: Service disruption
Postby rkulagow » Thu Jun 22, 2017 10:09 am

An update at our upstream had a side-effect of causing their image formation queries to bypass cache and generate heavy loads during high traffic hours.

I thought I had noticed a slowdown in gathering series images ... if you noticed too, you weren't imagining it.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#88 » Sun Jun 25, 2017 12:53 am

We're getting some errors in the response from SD for Md5 schedule entries. I'm not near my code so can't specifically identify the issue, but don't be surprised if some updates fail.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#89 » Sun Jun 25, 2017 2:11 am

Got a quick response from SD ... everything "looked" okay, but the servers were seeing a lot of traffic. Just checked and everything looks fine for EPG123 now and had a clean run.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#90 » Mon Jun 26, 2017 12:44 pm

Something is amiss..

[6/26/2017 1:15:00 AM] ===============================================================================
[6/26/2017 1:15:00 AM] Beginning epg123 update execution.
[6/26/2017 1:15:00 AM] ===============================================================================
[6/26/2017 1:15:00 AM] [ INFO] Beginning EPG123 update execution. 2017-06-26 08:15:00Z
[6/26/2017 1:15:00 AM] [ INFO] DaysToDownload: 30 , PrefixEpisodeTitle: True , AppendEpisodeDesc: True , TMDbCoverArt: True , LogoOverride: False , AutoAddNew: True
[6/26/2017 1:15:01 AM] [ INFO] Token request successful. serverID: 20141201.web.1
[6/26/2017 1:15:01 AM] [ INFO] Status request successful. account expires: 2018-03-24T11:39:31Z , lineups: 1/4 , lastDataUpdate: 2017-06-25T21:49:44Z
[6/26/2017 1:15:01 AM] [ INFO] system status: Online , message: No known issues.
[6/26/2017 1:15:01 AM] [ INFO] epg123 is up to date. version: 1.1.8
[6/26/2017 1:15:01 AM] [ INFO] Successfully retrieved TMDb configurations.
[6/26/2017 1:15:01 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[6/26/2017 1:15:01 AM] Entering buildLineupServices() for 1 lineups.
[6/26/2017 1:15:01 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-CA04768-X.
[6/26/2017 1:15:02 AM] Exiting buildLineupServices(). SUCCESS.
[6/26/2017 1:15:02 AM] Entering getAllScheduleEntryMd5s() for 30 days on 442 stations.
[6/26/2017 1:15:08 AM] [ INFO] Successfully retrieved Md5s for 442 station's daily schedules.
[6/26/2017 1:15:09 AM] [ INFO] Found 9030 cached daily schedules.
[6/26/2017 1:15:09 AM] [ INFO] Downloaded 0 daily schedules.
[6/26/2017 1:15:41 AM] [ INFO] Processed 9030 daily schedules for 442 stations.
[6/26/2017 1:15:41 AM] Exiting getAllScheduleEntryMd5s(). SUCCESS.


Nothing downloaded

9030 / 21 = 430, not 442
Sammy2
 
Posts: 1352
Joined: 24 August 2012
HTPC Specs: Show details

Post#91 » Tue Jun 27, 2017 1:06 am

Maybe, but you can't expect all 442 stations to have a full 21 days of data. What is unclear in your log is how long it was before the previous update? If it was 24 hours ago, then yah ... I would say something is amiss with 0 downloaded daily schedules.

My log from last night (1122Z -> 3 hours later than your update) showed normal downloads.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#92 » Mon Jul 31, 2017 4:14 pm

Sorry I never responded to this. All is well with the exception of a Schedules Direct Server down error last week. Don't remember which day it was as I was on vacation but I had clean runs for the last several runs and a full 21 days data right now.
Sammy2
 
Posts: 1352
Joined: 24 August 2012
HTPC Specs: Show details

Post#93 » Tue Aug 01, 2017 12:36 am

Sammy2 wrote:Sorry I never responded to this. All is well with the exception of a Schedules Direct Server down error last week. Don't remember which day it was as I was on vacation but I had clean runs for the last several runs and a full 21 days data right now.

Schedules Direct's servers were down for maintenance a few days ago ... at least that's what the server responded with. I do recall there being a banner on their webpage stating there were problems being worked.
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#94 » Tue Aug 01, 2017 5:32 am

garyan2 wrote:Schedules Direct's servers were down for maintenance a few days ago ... at least that's what the server responded with. I do recall there being a banner on their webpage stating there were problems being worked.

Yea, RobertK was doing some scheduled maintenance.

Every 5 minutes I run a test against the SD-DD and SD-JSON services. If there is one failure it says "possibly down". If there are two, it updates the banner to say it's down.... Once it comes back it says recovering until it's been up for a while (duration depends on outage length). After a few cycles it also starts sending text messages to us asking for help.
User avatar
rmeden
 
Posts: 59
Joined: 29 July 2015
Location: Schedules Direct

Post#95 » Tue Aug 01, 2017 11:23 am

rmeden wrote:
garyan2 wrote:Schedules Direct's servers were down for maintenance a few days ago ... at least that's what the server responded with. I do recall there being a banner on their webpage stating there were problems being worked.

Yea, RobertK was doing some scheduled maintenance.

Every 5 minutes I run a test against the SD-DD and SD-JSON services. If there is one failure it says "possibly down". If there are two, it updates the banner to say it's down.... Once it comes back it says recovering until it's been up for a while (duration depends on outage length). After a few cycles it also starts sending text messages to us asking for help.

That would explain why I got the bad gateway error last week. Does Schedules Direct post about these outages? I just looked on the SD forum and didn't see anything.
Alan G
 
Posts: 34
Joined: 22 February 2016
Location: Bethesda, Maryland
HTPC Specs: Show details

Post#96 » Tue Aug 01, 2017 2:06 pm

http://forums.schedulesdirect.org/viewforum.php?f=18

The Announcement at the top will have status. For the maintenance last weekend there was a message indicating that the service would be going down for maintenance approximately 7 days prior to the service window.
rkulagow
 
Posts: 225
Joined: 19 July 2015
Location: Schedules Direct

Post#97 » Tue Aug 01, 2017 2:10 pm

The gateway error you got was something else. For the down time this weekend there would have been a log entry stating the below.

SD responded with error code: 3000 , message: Server offline for maintenance....
User avatar
garyan2
 
Posts: 2200
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#98 » Tue Aug 01, 2017 6:42 pm

Thanks to both for responding to my question. Since the gateway error last week, things have been working fine.
Alan G
 
Posts: 34
Joined: 22 February 2016
Location: Bethesda, Maryland
HTPC Specs: Show details

Post#99 » Tue Aug 01, 2017 7:27 pm

My media guide has been stuck at an End Date of "8/8/2017 10 PM" for several days or more. I check the SD page and don't see anything wrong there. In my event logs, it shows that my media "package is already up to date." I am new to EPG123/SD is there something wrong with my set up or SD? When I first switched from Rovi to EPG123/SD, I think I had almost three weeks of media guide data, and I was ecstatic. Now, I am down to less than a week. Suggestions?

Thanks.

Steve
kodi2k6
 
Posts: 3
Joined: 18 July 2017

Post#100 » Tue Aug 01, 2017 7:34 pm

There are 400 users pulling updates right now, so there's no service issue at Schedules Direct.
rkulagow
 
Posts: 225
Joined: 19 July 2015
Location: Schedules Direct

PreviousNext

Return to EPG123



Who is online

Users browsing this forum: No registered users and 2 guests

cron