WMC Crashes When Scheduling OTA Program Recording

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

WMC Crashes When Scheduling OTA Program Recording

Post#1 » Fri May 05, 2017 12:57 pm

Only after Windows is rebooted am I able to schedule a recording, and only once. Any attempt to schedule more than 1 recording (or series) between reboots results in WMC crashing again.

Edit: Programs aren't recording either. I tried to manually record a program during the time it was supposed to record and got the error message 'The recording could not be scheduled for an unknown reason. Restart Media Center and try to schedule your recording again.'
Posts: 14
Joined: 2 May 2017

Post#2 » Fri May 05, 2017 2:03 pm

That. Does not sound good. It might be time to uninstall and re-install WMC. After the uninstall, delete the eHome folder in ProgramData, just to be sure it's clean. You could try EPG123's "clean" command (I forget the exact name) in Safe Mode, but the un-/re-install is the full nuclear solution. Then, you can start from scratch and use EPG123 with a clean WMC database.
User avatar
Posts: 64
Joined: 6 October 2014
USA 60005
WOW Chicago Suburbs - Digital

Post#3 » Fri May 05, 2017 2:45 pm

arcturus is newly moved over to epg123 and essentially did the uninstall/reinstall and clean start due to some complications. I agree this sounds like a database problem, but it could also be a windows search/indexing problem. Before the nuclear option is tried, I'd like to check a few things first.

Did you use anything like MCBackup to try and restore previous scheduled recordings you had with Rovi?

Any add-ons installed in WMC?

Other than problems adding scheduled recordings, does everything else appear to be working properly?

If you do a search, do legitimate results show up?

Options other than nuclear:
If the searches don't appear to work, check your Indexing Options from the control panel and verify WMC is enabled.

If the searches still don't appear to work, run "START /WAIT c:\windows\ehome\mcupdate.exe -ReindexSearchRoot"

Run "START /WAIT c:\windows\ehome\mcupdate.exe -PvrRecoveryTask" to reset the scheduled recordings.

Boot into safe mode, run epg123Client.exe, and select the [Rebuild Database] button. Once you boot back into normal mode, run epg123Client.exe and click [Manual Import] to import your latest guide listings again.

There a couple more mcupdate options to click, but don't know if they would work if the above doesn't.
User avatar
Posts: 2708
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#4 » Sat May 06, 2017 1:37 pm

I've nuked eHome and started fresh a number of times. SD should probably hit me with a bandwidth penalty for the number of times I've pulled down data as I've gone so far as to nuke the EPG directory as well.

No backup and restore, or add-ons. Search queries work fine. Everything else works except for one of its primary functions - to record.

At this point I'm not seeing any other recourse (unless anyone has other suggestions) but to install Win 7 in a VM to rule out registry corruption. There are registry keys which seem to show WMC scheduling directives but I have no way to determine their integrity nor whether they're affected or altered by any WMC uninstalls/reinstalls that I've also done.

I'm left with a nagging feeling that any latent issues relating to WMC may somehow be triggered by all this effort.

Will try a basic Win 7 install, try it again, take an image snapshot, and hope if successful that updates (which could take a week) won't foul it up again.
Posts: 14
Joined: 2 May 2017

Post#5 » Sat May 06, 2017 2:46 pm

If you think it might be a registry issue, the below is how to "restore" WMC to the OOBE stage. Just need to delete some keys and create a couple empty keys. I would recommend doing it in Safe Mode to be sure background services are not running and while in safe mode go ahead and delete C:\ProgramData\Microsoft\eHome folder again. This is the first reported issue like this with over 1000 users, so I'm pretty sure we can figure this out and get you up and running.

HKLM\Software\Microsoft\Windows\CurrentVersion\Media Center

Delete Keys:
Service\Content Security\Shared

Create Empty Keys:
User avatar
Posts: 2708
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#6 » Mon May 08, 2017 4:34 pm

First, let me say that I've appreciated all your help.

The registry edits did not work.

Service\ehPrivJob\OCURDevices was missing. There was Service\ehPrivJob\OCURActivate which I didn't touch. OCURDevices is present now after the edit and subsequent reboot.

Discovery\Locater was also missing.

There was some type of WMC 'PlayReady' runtime EULA approval. I clicked 'do not agree' and skipped it.

3 error messages noted. A transient, windows generated 'unable to record error message -12xxxxxxxx at first. Don't recall the numbers. Haven't seen it since.

Second, the inability to record more than 1 show concurrently. Message stating something to this effect. Then, after reboot, I tried again and it was accepted. Scheduling 1 recording DID record for a bit but multiple shows set to record end up with none of them recorded.

Finally, an immediate WMC crash trying to record/unrecord programs, excluding those who appear to accept the record directive but don't.

As before, queries do work.

Just for the heck of it I installed EPG on a second second computer on its last legs. Worked fine, no issues.

Tried to run it in a Win 7 VM. Doesn't appear HdHomerun Dual works properly ... maybe vid codecs of vid memory. Since it couldn't pull stations, no sense installing EPG.

I'm out of time so call me the 1 out of 1000 apparently.

Thanks again.
Posts: 14
Joined: 2 May 2017

Post#7 » Sat Mar 10, 2018 4:49 pm

I had this exact problem:

All roads led back to the task manager which had failed (Trying to start it yielded an error "Remote machine not found" and had most buttons greyed out). The solution is actually very simple and I found two.

Start > Run > Regedit
Export this key to back it up first, then delete the whole Internet key (and it's sub-keys).
Reboot your system
Task Scheduler should now work.

If your system has no Internet entry under RPC then the solution is even simpler:

Go to the command prompt (Start > Type in CMD), then type "netsh winsock reset", then hit enter.

Once it's completed, restart your computer.

All scheduled recordings will now complete normally and new recordings will be able to be scheduled as well.
Posts: 21
Joined: 5 December 2014

Return to EPG123

Who is online

Users browsing this forum: mldenison and 1 guest