After upgrading from 1.0.1 to 1.1.3, WMC crashes

An evolving, supported alternative to Rovi
Important Information
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf

Re: After upgrading from 1.0.1 to 1.1.3, WMC crashes

Post#21 » Tue Mar 14, 2017 10:58 pm

IT Troll wrote:Just a wild stab in the dark. Could it be the episode/series images? That it something which EPG123 adds over the Rovi. Perhaps an underlying problem on the system manifests whilst trying to display these images.

Would in be possible to strip the image references prior to import as a test?

I kind of thought along the same lines which is why I suggested emptying the internet explorer cache. There is no easy method to remove the image references from the mxf file, and even then, you would have to start from scratch again. The image references may be removed from the mxf file, but it is still in the database from the last import.

Also, the image used in the guide is the same image used in the details, and WMC had problems using Rovi without EPG123 data.
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#22 » Tue Mar 14, 2017 11:46 pm

So clearing the cache would delete all the images so there is nothing to display? Or would Media Center just download them again?

It does sound like some third-party viewer or filter is getting in the way to me.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#23 » Tue Mar 14, 2017 11:53 pm

They would have to be downloaded again which I why I wouldn't expect it to make a difference.
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#24 » Thu Mar 16, 2017 6:38 pm

garyan2 wrote:I haven't found anything to lead to a root cause with epg123... considering mine and everyone else's success. This may simply be a WMC, .NET, Windows thing. Was there anything special about the specific listing crashing with just the Rovi data?

My next suggestion would be to clear the Internet Explorer cache (WMC uses it for downloaded images), but I wouldn't expect any difference.

There are quite a few suggestions here, as well.

Pretty much everything I've found focuses on DirectX, video codecs and drivers, .NET frameworks and some have only been resolved by uninstalling WMC and resinstalling.

When using Rovi, the crash only happens when clicking on SOME new listings (5pm news). With EPG123/SD, every listing causes a crash. However, I don't think this is an EPG123 issue at all.

I tried reinstalling WMC several times, uninstalling .Net Framework 4.6.2 as well as all of the suggestions in the link you provided, no luck. I am going to try a clean install of Windows.
User avatar
Scallica
 
Posts: 2375
Joined: 6 June 2011
Location: USA!
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

Post#25 » Sat Mar 18, 2017 10:41 pm

Remember to stir anti-clockwise.
User avatar
STC
 
Posts: 6793
Joined: 6 June 2011
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
By the Community, for the Community. 100% Commercial Free.

Want decent guide data back? Check out EPG123

Post#26 » Thu Mar 23, 2017 10:41 pm

I just had a similar crash whilst browsing through the guide. At the same time, my router had lost Internet connectivity. So, I believe this is further evidence towards this being an image download issue. After a quick router reboot my Internet was back and the guide once again worked as expected.

Perhaps other interruptions in the image retrieval process can cause EHShell.exe to crash. Possibly even something like overzealous security software which blocks access whilst it scans the download?

Anyway here are the Event Log entries:

Code: Select all
<Events>
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error"/>
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-03-23T21:29:14.000000000Z"/>
<EventRecordID>45034</EventRecordID>
<Channel>Application</Channel>
<Computer>HTPC</Computer>
<Security/>
</System>
<EventData>
<Data>EHShell.exe</Data>
<Data>6.3.9600.16384</Data>
<Data>5215efc2</Data>
<Data>KERNELBASE.dll</Data>
<Data>6.3.9600.18340</Data>
<Data>57366075</Data>
<Data>e0434352</Data>
<Data>0000000000008a5c</Data>
<Data>1418</Data>
<Data>01d2a12e968f4ed2</Data>
<Data>C:\Windows\eHome\EHShell.exe</Data>
<Data>C:\Windows\system32\KERNELBASE.dll</Data>
<Data>c2cec752-100f-11e7-82c1-305a3a092522</Data>
<Data/>
<Data/>
</EventData>
</Event>
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name=".NET Runtime"/>
<EventID Qualifiers="0">1026</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-03-23T21:29:14.000000000Z"/>
<EventRecordID>45033</EventRecordID>
<Channel>Application</Channel>
<Computer>HTPC</Computer>
<Security/>
</System>
<EventData>
<Data>
Application: EHShell.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.ObjectDisposedException Stack: at System.Net.Cache.ForwardingReadStream.EndRead(System.IAsyncResult) at Microsoft.MediaCenter.UI.WebResource.AsyncContentStreamCallback(System.IAsyncResult) at System.Net.LazyAsyncResult.Complete(IntPtr) at System.Net.Cache.ForwardingReadStream.ReadComplete(System.IAsyncResult) at System.Net.LazyAsyncResult.Complete(IntPtr) at System.Net.FixedSizeReader.ReadCallback(System.IAsyncResult) at System.Net.LazyAsyncResult.Complete(IntPtr) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Net.ContextAwareResult.Complete(IntPtr) at System.Net.Sockets.BaseOverlappedAsyncResult.CompletionPortCallback(UInt32, UInt32, System.Threading.NativeOverlapped*) at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)
</Data>
</EventData>
</Event>
</Events>
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#27 » Thu Mar 23, 2017 10:45 pm

I had a similar issue (media center crashing) and the only recent change was going to EPG 1.3 I reverted back to 1.11 (?) and it hasn't done it since, as far as I can recall.
marvin-miller
 
Posts: 219
Joined: 18 September 2012
HTPC Specs: Show details

Post#28 » Thu Mar 23, 2017 10:59 pm

IT Troll wrote:I just had a similar crash whilst browsing through the guide. At the same time, my router had lost Internet connectivity. So, I believe this is further evidence towards this being an image download issue. After a quick router reboot my Internet was back and the guide once again worked as expected.

Perhaps other interruptions in the image retrieval process can cause EHShell.exe to crash. Possibly even something like overzealous security software which blocks access whilst it scans the download?

Anyway here are the Event Log entries:



This implies that just unplugging your machine from the net may be enough to reproduce I would think.
stuartm
 
Posts: 323
Joined: 5 November 2012
Location: Longmont, CO
HTPC Specs: Show details

Post#29 » Thu Mar 23, 2017 11:11 pm

stuartm wrote:This implies that just unplugging your machine from the net may be enough to reproduce I would think.

I think it perhaps requires a sudden unexpected interruption. Quite difficult to recreate artificially.
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#30 » Fri Mar 24, 2017 3:21 am

Possible. The original problem Scallica was having may have been due to the rebuild of the image links on the SD servers at the time ... basically reset everything so the initial links were to schedules direct for a redirect to the AWS servers. It may have been the redirects which weren't working.
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#31 » Tue May 02, 2017 3:00 pm

Scallica wrote:I am going to try a clean install of Windows.

I did a clean install of Windows 7 Pro SP1, then setup WMC with EPG123 v1.1.4. WMC still crashes when I select any listing in the guide. :what the heck:
User avatar
Scallica
 
Posts: 2375
Joined: 6 June 2011
Location: USA!
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

Post#32 » Wed May 03, 2017 12:50 am

Scallica wrote:
Scallica wrote:I am going to try a clean install of Windows.

I did a clean install of Windows 7 Pro SP1, then setup WMC with EPG123 v1.1.4. WMC still crashes when I select any listing in the guide. :what the heck:

NOT.A.CLUE. :what the heck: :crazy:
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#33 » Wed May 03, 2017 3:03 am

Scallica, what's your lineup? I'm going to setup a VM and try to duplicate.
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#34 » Fri May 05, 2017 8:04 pm

I figured out what was causing the crash. My firewall's security services was preventing WMC from accessing one of Microsoft's servers. :crazy:
User avatar
Scallica
 
Posts: 2375
Joined: 6 June 2011
Location: USA!
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

Post#35 » Fri May 05, 2017 9:00 pm

That's disconcerting. What happens to all of us using WMC when Microsoft shuts down this server? Do you know what it was being accessed for?
One of the reasons I went to EPG123 was to break any dependency on Microsoft.
stuartm
 
Posts: 323
Joined: 5 November 2012
Location: Longmont, CO
HTPC Specs: Show details

Post#36 » Fri May 05, 2017 9:36 pm

stuartm wrote:That's disconcerting. What happens to all of us using WMC when Microsoft shuts down this server? Do you know what it was being accessed for?
One of the reasons I went to EPG123 was to break any dependency on Microsoft.


Rest easy. I went to Tasks-->Settings-->General-->Automatic Download Options and unchecked both boxes. Now it works great :thumbup:
User avatar
Scallica
 
Posts: 2375
Joined: 6 June 2011
Location: USA!
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

Post#37 » Fri May 05, 2017 10:10 pm

Cool, good to know, Thanks
Glad to hear you finally got it all working.
stuartm
 
Posts: 323
Joined: 5 November 2012
Location: Longmont, CO
HTPC Specs: Show details

Post#38 » Sat May 06, 2017 12:16 am

Hmmmm... I've actually encouraged everyone to keep the boxes checked (at least the first one) to download the extended movie information and DVD/CD meta. I've never had a problem.

Gonna have to rethink that recommendation, I guess.
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post#39 » Sun May 07, 2017 3:43 pm

Glad to hear you go to the bottom of this. The firewall being the cause has some synergy with the crash I experienced whilst my router had a funny turn. I guess WMC doesn't handle unexpected networking issues so well.

Strange that the problem was apparently worse with EPG123 guide data though. Do you still get the episode/series images with those boxes unchecked?
User avatar
IT Troll
 
Posts: 496
Joined: 27 November 2011
Location: Edinburgh, UK
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#40 » Sun May 07, 2017 3:57 pm

Actually, phrasing like that it makes sense why EPG123 was worse. In order to show actor roles in series episodes, I had to flag (turn on) the extended actor information for all the programs. It looks like having that flag set forces WMC to make a call to the internets and attempt to fill that information. Normal WMC behavior would be to do that for movies 1 time only. With EPG123, it would be doing it for movies and episodes always.

I wonder if there is a way to change that behavior?
User avatar
garyan2
 
Posts: 2197
Joined: 27 November 2015
HTPC Specs: Show details
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

PreviousNext

Return to EPG123



Who is online

Users browsing this forum: No registered users and 2 guests

cron