Cumulative update KB4013418 and KB4013429 = WMC KO !

Discussion of getting WMC to work on Windows 10 (unsupported)

Re: Cumulative update KB4013418 and KB4013429 = WMC KO !

Post#21 » Sun Mar 19, 2017 6:00 pm

All it is doing is providing a simple procedure to automate finding the old version (10.0.14393.0) of CompPkgSup.dll and copy it to the current directories so overwriting the newer version (10.0.14393.953) of the same file that has broken WMC. You can do this manually but need to take ownership of the .dll file which this fix will do for you. As you will note from my earlier post Microsoft is aware of the bug.
ChrisJ
 
Posts: 5
Joined: 18 March 2017

Post#22 » Sun Mar 19, 2017 9:53 pm

ChrisJ wrote:. As you will note from my earlier post Microsoft is aware of the bug.


Thanks for the information. Let's wait and see then.
User avatar
lachape_one
 
Posts: 48
Joined: 6 May 2016
Location: Versailles, France
HTPC Specs: Show details

Post#23 » Mon Mar 20, 2017 1:16 pm

Crash2009 wrote:Can anyone here read this language? KAPUT is about the only word I understand.

It appears MPEG and WTV are broken in Win10 14393

http://www.drwindows.de/windows-10-desk ... ost1372106

THANKS to: Grizu_1968 and OlliD@IRQ8 for the fix. (if it works)

https://forums.mydigitallife.info/threa ... ost1328264


This is a handy script for people who want an easy method of fixing the problem on a number of PCs but unfortunately, it doesn't work for users with an English Language system because it originated in Germany and it takes ownership of the DLLs for a nonexistent group.
To make it work, alter both instances of the word administratoren to administrators. IDK about other languages.
The other problem for me was that as per another of my posts, the old (version 10.0.14393.0) files stored in my winsxs folders have mysteriously shrunk from 38kb and 33kb to 5kb and 4.4kb and they don't work any more (this wasn't an issue for me because I made a backup of the old files as soon as the resolution to this problem was highlighted by @Darkradeon). Thanks go to him for that.
technodevotee
 
Posts: 64
Joined: 10 September 2015
Location: West Midlands
HTPC Specs: Show details

Post#24 » Mon Mar 20, 2017 7:21 pm

This has been fixed with update KB4015438. with WMC anyways.
kobbit
 
Posts: 1
Joined: 20 March 2017

Post#25 » Mon Mar 20, 2017 7:27 pm

Details of this update can be found at this link: https://support.microsoft.com/en-au/hel ... -kb4015438
You will note that it states:
•Addressed a known issue with KB4013429 that caused Windows DVD Player (and 3rd party apps that use Microsoft MPEG-2 handling libraries) to crash.
Well done to MS for the quick response.

I should perhaps add that whatever else it does, this update installs CompPkgSup.dll version .969 whereas the version that caused all the problems was .953

I have tested the update, and can confirm that it has solved the problems in my setup.
ChrisJ
 
Posts: 5
Joined: 18 March 2017

Post#26 » Wed Mar 22, 2017 10:21 am

Just checking. I replaced the dll and that fixed the problem. If I now apply KB4013429, does that undo that replacement of the DLL and returnme to a 'pukka' version of Windows 10 - or do I need to do something else to achieve that?
bb193
 
Posts: 12
Joined: 4 August 2016

Post#27 » Wed Mar 22, 2017 10:56 am

My experience, having originally replaced the .dll with the version the earlier that worked was that after I had installed the KB4013429 update, the version had changed to .969 which also works. As far as I can see we now have a fully functioning standard version of Windows 10, up to date. Nothing else needs changing.

No doubt the Creator's Update is going to bring some new challenges when it is released shortly although I do understand we might have more options whether or not to install than has been past practice with Windows Updates.
ChrisJ
 
Posts: 5
Joined: 18 March 2017

Post#28 » Wed Mar 22, 2017 3:01 pm

Microsoft released a new Cumulative update to correct the MPEG-2 libraries they broke that caused this issue.

https://www.onmsft.com/news/windows-10- ... o-pc-users

I am installing it now and will report back.
User avatar
Venom51
 
Posts: 538
Joined: 12 June 2011
Location: Cumming,GA
1+ YrsTGB Veteran

Post#29 » Wed Mar 22, 2017 3:25 pm

New update appears to fix the issue.
User avatar
Venom51
 
Posts: 538
Joined: 12 June 2011
Location: Cumming,GA
1+ YrsTGB Veteran

Post#30 » Thu Mar 23, 2017 7:12 am

Venom51 wrote:New update appears to fix the issue.


Do you have any thoughts re: What was MS working on when they broke this?
User avatar
Crash2009
 
Posts: 3696
Joined: 17 May 2012
Location: Ann Arbor, Michigan
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#31 » Thu Mar 23, 2017 10:40 am

Crash2009 wrote:
Venom51 wrote:New update appears to fix the issue.


Do you have any thoughts re: What was MS working on when they broke this?


some people resolved the problem by uninstalling KB4014329 and the info on that says

quote
This security update resolves vulnerabilities in Adobe Flash Player if it's installed on any supported edition of Windows Server 2016, Windows Server 2012 R2, Windows Server 2012, Windows 10, Windows 10 Version 1511, Windows 10 Version 1607, Windows 8.1, or Windows RT 8.1.

To learn more about the vulnerability, see Microsoft Security Bulletin MS17-023
/quote

I don't know how a critical security update to resolve vulnerabilities in Adobe Flash Player that breaks *everything* that uses Microsoft MPEG-2 libraries can be allowed out of the sandbox but they (MS) really wanted the vulnerability gone because, as I said in another post, the update also seems to have modified the original DLLs stored in winsxs and if you put them back, while the apps that had started crashing don't crash any more, there's sound but no video.
technodevotee
 
Posts: 64
Joined: 10 September 2015
Location: West Midlands
HTPC Specs: Show details

Post#32 » Fri Mar 24, 2017 8:29 pm

If you have uninstalled KB4014329, then now it needs to install KB4014329 again, with reboot, and then it will download KB4015438, install and reboot agaib. Both KB needs a long time to download and install. You need to be patient. But works.

I think also that installing KB4015438 has speed up my Netbook again. Last weeks it was sometimes really like slow motion, specially in Thunderbird and Firefox.
1ST1
 
Posts: 13
Joined: 20 December 2016

Post#33 » Fri Mar 24, 2017 9:04 pm

1ST1 wrote:I think also that installing KB4015438 has speed up my Netbook again. Last weeks it was sometimes really like slow motion, specially in Thunderbird and Firefox.


I noticed the same here a very high CPU usage (20%) when I use WMC or WMP
User avatar
lachape_one
 
Posts: 48
Joined: 6 May 2016
Location: Versailles, France
HTPC Specs: Show details

Previous

Return to Windows 10 Media Center



Who is online

Users browsing this forum: No registered users and 1 guest

cron