Amazon On-Demand Video Addin for Media Center

Re: Amazon On-Demand Video Addin for Media Center

Post#201 » Sun Jan 28, 2018 10:01 pm

I just posted a guide for how I got the Amazon addon for Kodi integrated into the WMC menu:

http://www.thegreenbutton.tv/forums/viewtopic.php?f=9&t=11491
tonywagner
 
Posts: 25
Joined: 4 February 2016

Post#202 » Mon Jan 29, 2018 12:20 am

I'll add to this that kodii has add-ons for Netflix and Spotify as long as your on version 18 I believe. If someone is looking for a lot of streaming content to fill in for what WMC is missing then Kodi might help with that. For you Tony I think a lot of people are going to want to be sure their systems stay stable when adding Kodi on top of WMC
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#203 » Tue Apr 03, 2018 3:14 pm

Hi All,

Quick update - due to overwhelming demand I have pulled the Amazon Prime code out of retirement and will be releasing a new version shortly which will fix the playback issues. Look for an update on my site in about a week or two. Thanks,

Marc
https://sharepointadept.com/amazonmceaddin/
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#204 » Wed Apr 04, 2018 1:24 am

Glad to hear it!!
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#205 » Wed Apr 04, 2018 1:38 am

4/3/2018 UPDATE: Hello everyone; I have pulled the Amazon Prime code out of retirement and am giving you guys the updates you asked for! Version 2.0 Build 20180402 is now available. This version has a bunch of changes - including a new video player/remote control proxy based on my Netflix work; fixes for My Movies and My TV Series views; updated branding and a bunch of code improvements. This version removes the Mongoose web server components and is no longer affected by those pesky incompatible Windows Updates. It MAY even work for Non-USA folks now - someone try it and let me know.

Not sure how many more releases there will be - but this one should get most of you working again. Also - this new version only has about 5 hours of testing done to it; I need you guys to test it and let me know how it is working.  The remote-proxy has only been tested with the Silverlight player; I have not tried the HTML5 player yet. I have put compatibility settings in to force Silverlight in most cases.
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#206 » Wed Apr 04, 2018 7:21 pm

Does this have any kind of google chrome dependencies?
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#207 » Wed Apr 04, 2018 7:25 pm

jachin99 wrote:Does this have any kind of google chrome dependencies?


Nope.
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#208 » Wed Apr 04, 2018 8:26 pm

I'm having trouble with two machines that I have installed this on but a third one works fine. For the two that don't work, I can naviagate everything in WMC but when i select something to watch, WMC minimizes and nothing happens. I'm guessing this launches IE in a fullscreen window so is there some setting in IE I have to change? Sorry for the trouble, and thanks for your help. i should also say that I have Silverlight installed, and I have disabled enhanced protected mode in IE.
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#209 » Wed Apr 04, 2018 8:33 pm

It doesn't launch IE - it launches a custom EXE which uses the webbrowser control. Be sure you have IE10 or later installed and the .NET Framework 3.51 installed.
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#210 » Wed Apr 04, 2018 11:49 pm

I thought 3.5 was installed on Win 7 out of the box. I don't see it under programs and features though. I tried installing it anyway on one machine but the installtion does nothing. It asks me to allow the program to make changes, I hit yes, then nothing happens. I even used the .net verification tool, and it says I have it.
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#211 » Thu Apr 05, 2018 12:34 am

jachin99 wrote:I thought 3.5 was installed on Win 7 out of the box. I don't see it under programs and features though. I tried installing it anyway on one machine but the installtion does nothing. It asks me to allow the program to make changes, I hit yes, then nothing happens. I even used the .net verification tool, and it says I have it.


In the Program Files folder for my app there should be an exe called 'PrimeVideoPlayer.exe'. Run it and one of two things will happen if it is working properly; it will either play the last video you selected or you will get a black screen with a warning message. Let me know what you get.
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#212 » Thu Apr 05, 2018 12:37 am

It says prime video player stopped working. Here are the details

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: primevideoplayer.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 5ac422b8
Problem Signature 04: PrimeVideoPlayer
Problem Signature 05: 1.0.0.0
Problem Signature 06: 5ac422b8
Problem Signature 07: 2a
Problem Signature 08: 39
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#213 » Thu Apr 05, 2018 1:19 am

jachin99 wrote:It says prime video player stopped working. Here are the details

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: primevideoplayer.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 5ac422b8
Problem Signature 04: PrimeVideoPlayer
Problem Signature 05: 1.0.0.0
Problem Signature 06: 5ac422b8
Problem Signature 07: 2a
Problem Signature 08: 39
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt



OK- Odd - there should have been a file present; Is this installed on the C or D drive?
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#214 » Thu Apr 05, 2018 1:25 am

KerrAvon wrote:
jachin99 wrote:It says prime video player stopped working. Here are the details

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: primevideoplayer.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 5ac422b8
Problem Signature 04: PrimeVideoPlayer
Problem Signature 05: 1.0.0.0
Problem Signature 06: 5ac422b8
Problem Signature 07: 2a
Problem Signature 08: 39
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt



OK- Odd - there should have been a file present; Is this installed on the C or D drive?
C drive. I have .net 4.7 I believe installed on these machines as well.

Sent from my Pixel XL using Tapatalk
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#215 » Thu Apr 05, 2018 1:44 am

I think your pcs may be missing a dependency dll; I have repackaged the app - re-download it from my blog now and try it.
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

Post#216 » Thu Apr 05, 2018 2:42 am

It looks like your a step closer but I get a screen that says no video selected return to WMC. This new build has only been tested in one machine that is 32 bit. I'll have to pick this back up tomorrow. I did uninstall the old version first if that helps but I reinstalled your new one without restarting. I'll test on my other machine tomorrow and let you know how it goes. I really appreciate you bringing this back and thanks for the help
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#217 » Thu Apr 05, 2018 12:32 pm

IS this even still working ? Amazon changed something major, his plugin didn't work with it and he moved from WMC so he even took down his site for it.
User avatar
DavidinCT
 
Posts: 1297
Joined: 13 February 2012
5+ YrsTGB VeteranMicrosoft MVP
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Post#218 » Thu Apr 05, 2018 12:38 pm

IT does still work for me. Don't read into my troubles too much. Its an entirely new app and it even looks a little different but the best thing about it is it doesn't launch in IE anymore. Remote control commands seem to work with it but I haven't tested all of them yet, and videos launch fullscreen, and return to WMC when they're done playing. If he gets everything sorted out then it should be a great addition to WMC.
jachin99
 
Posts: 795
Joined: 24 February 2016

Post#219 » Thu Apr 05, 2018 12:57 pm

jachin99 wrote:IT does still work for me. Don't read into my troubles too much. Its an entirely new app and it even looks a little different but the best thing about it is it doesn't launch in IE anymore. Remote control commands seem to work with it but I haven't tested all of them yet, and videos launch fullscreen, and return to WMC when they're done playing. If he gets everything sorted out then it should be a great addition to WMC.


Oh. crap, he did update it. He said in the past that he gave up on WMC so he was not going to update it, just checked his changed site and he updated it and you don't have to deal with those incompatible Windows updates (you had to roll back to a early version of WMC before)

I'll have to try this tonight... It was just updated yesterday, so if you did not update it, you should try to update yours.

https://sharepointadept.com/amazonmceaddin/

https://sharepointadept.com/amazonmceaddin/ wrote:4/4/2018 UPDATE: Hello everyone; I have pulled the Amazon Prime code out of retirement and am giving you guys the updates you asked for! Version 2.0 Build 20180404 is now available. This version has a bunch of changes – including a new video player/remote control proxy based on my Netflix work; fixes for My Movies and My TV Series views; updated branding and a bunch of code improvements. This version removes the Mongoose web server components and is no longer affected by those pesky incompatible Windows Updates. It MAY even work for Non-USA folks now – someone try it and let me know.


Maybe there is a quick way to add Amazon prime streaming to WMC....finally
User avatar
DavidinCT
 
Posts: 1297
Joined: 13 February 2012
5+ YrsTGB VeteranMicrosoft MVP
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Post#220 » Thu Apr 05, 2018 1:00 pm

jachin99 wrote:It looks like your a step closer but I get a screen that says no video selected return to WMC. This new build has only been tested in one machine that is 32 bit. I'll have to pick this back up tomorrow. I did uninstall the old version first if that helps but I reinstalled your new one without restarting. I'll test on my other machine tomorrow and let you know how it goes. I really appreciate you bringing this back and thanks for the help


Did you get that msg by running the exe directly or after picking a movie in media center? if the latter - email me the plugin.log file from the program files folder; support@sharepointadept.com; could also be a permissions issue on the program folder; make sure your ID has full control as it needs to write things to the folder to make this work.

MD
KerrAvon
 
Posts: 48
Joined: 6 December 2013
Location: New Jersey
HTPC Specs: Show details

PreviousNext

Return to WMC Add-ins and 3rd Party Apps



Who is online

Users browsing this forum: No registered users and 1 guest

cron