[HOW TO] Configuring Remote Access Outside of the House

For general setup and troubleshooting issues

[HOW TO] Configuring Remote Access Outside of the House

Post#1 » Fri Sep 21, 2012 5:46 am

//Original thread post
we have 2 computers and 2 ceton apps. 1 for each computer. If i use port forwarding both ceton apps will only work with the computer thats in port forwarding. I turned off port forwarding now everything works fine over the wifi at home. but it wont anywere else. How can i fix this?

Can i put both ip address of the computers in port forwarding?


//Motz
To use the app remotely and off wi-fi you need to enable port forwarding on your router. We have a small guide here:
http://cetoncorp.com/documents/MyMediaC ... sGuide.pdf

Also you can find guides to your specific router here:
http://portforward.com/english/applicat ... efault.htm
tootal2
 
Posts: 99
Joined: 9 September 2012

Post#2 » Fri Sep 21, 2012 2:00 pm

Note: I made this thread a sticky for others.

*~*~*~*~*~*~*~*~*~*~*~*~*~*~~*~*~*~*~*~*~*~

You have two choices.

1- Setup a different internal port for Companion Services on PC2 and use Network Address Translation (NAT) to forward the port.

2- Setup a different external port for Companion Services on PC2 and use Network Address Translation (NAT) and Port Address Translation (PAT) to forward the port.

Note: I am assuming you are using NAT...which most people do use (I don't myself)

Note: Many routers support Port Triggering in addition to Port Forwarding. They do essentially the same thing with the exception that Port Triggering only forwards the port when there is an application listening on the specified port. For instance, if your HTPC is configured for sleep as soon as your PC goes to sleep the port forward would no longer be enabled.

NAT Only

1- Setup PC1 so it is working properly using the defaults

2- Pick a different internal port for PC2. Lets say 5985.

3- On PC2 open Ceton Companion Config and goto Advanced -> Network

4- Leave the external port as 0 (or 5985 if you prefer to be explicit)

5- Save and close Ceton Companion

6- On your router\firewall setup an additional NAT rule but use 5985 for PC2 instead of the default port 5984

NAT + PAT

Note: While almost all modern routers\firewalls support PAT some older ones don't. If yours does not probably time for a new router.

1- Setup PC1 so it is working properly using the defaults

2- Pick a different external port for PC2. Lets say 5985.

3- On PC2 open Ceton Companion Config and goto Advanced -> Network

4- Leave the internal port as 5984

5- Set the external port as 5985

5- Save and close Ceton Companion

6- On your router\firewall setup an additional NAT rule using 5985 as the external port and 5984 as the internal port.

Hope this helps. If you need more explicit instructions please provide the make and model of your router.
mikinho
 
Posts: 248
Joined: 16 June 2011
5+ YrsTGB VeteranMicrosoft MVP

Post#3 » Sat Sep 22, 2012 4:59 pm

Additionally our guide for remote access can be found here: http://cetoncorp.com/documents/CetonCompanionRemoteAccessGuide.pdf

Portforwarding.com gives you a great guide for nearly every router how to port forward: http://portforward.com/english/routers/port_forwarding/routerindex.htm
User avatar
Motz
 
Posts: 2038
Joined: 14 January 2012
Location: Seattle, WA
HTPC Specs: Show details
2+ YrsTGB Veteran
I Write, Code, and Tweet


Return to How To Guides



Who is online

Users browsing this forum: No registered users and 1 guest

cron