Netflix freezing media center

Netflix freezing media center

Post#1 » Mon Oct 10, 2011 4:18 pm

Recent Netflix changes to the Media Center add-in have been causing media center to crash (freeze completely) at the very end of a movie. The last screen of the movie is frozen on screen and control never gets back to the netflix interface nor is navigation possible. Yikes. Has anyone had issues lately? First time this happened was yesterday and it has continued today.
User avatar
EmirOfGroofunkistan
 
Posts: 151
Joined: 20 June 2011
HTPC Specs: Show details

Post#2 » Mon Oct 10, 2011 4:55 pm

I've noticed that too. Not so good for some tv shows that have clips right up to the last moment... better for shows where I stop during the end credits. At least for now, try to anticipate stopping before the end of the last frame.

i've also noticed that a lot of movies are stopping streaming recently at the get-go. I'm not sure if its just me, as I just installed a new router... will need to do some troubleshooting.
User avatar
makryger
 
Posts: 2019
Joined: 5 June 2011
Location: Illinois
HTPC Specs: Show details
5+ YrsTGB VeteranStaff
My Channel Logos XL: Get your Guide looking good! ~~~~ TunerSalad: Increase the 4-tuner limit in 7MC

Post#3 » Mon Oct 10, 2011 10:42 pm

Excellent, others have noticed this too. (The voices were telling me that I was crazy.)

At first I thought it was the recent IE9 update but I rolled that back and nothing changed - 100% of the time, finishing a movie causes it to hang.

When I go to the task manager, it reports that Media Center is running; but I just get a black screen.
I tried watching a video though the IE browser and it completes properly. It goes to a NetFlix RedScreen that prompts you to "Go Back to Browsing". This is what we media center people are missing - that pop to redscreen. Is this new?? Did NetFlix change something?

It seems like the short term fix is to not let the movie terminate but is not great because the kids watch short episodes or walk away, I tend to fall asleep sometimes.

Please keep plugging away and post the solution here when you find it.
User avatar
peterc408
 
Posts: 4
Joined: 10 October 2011
HTPC Specs: Show details

Post#4 » Mon Oct 10, 2011 11:54 pm

same here. It is driving my wife batty. I noticed it at about the time they fixed the issue with adding to the instant queue.
gcballard
 
Posts: 1
Joined: 10 October 2011

Post#5 » Tue Oct 11, 2011 12:16 am

Interesting... We seem to have a small group forming.
Did you folks recently allow a Windows Update?

I am running WMC on Windows 7 (64-bit)
I installed the Netflix plug-in for WMC over a year ago and have used it daily.
I checked their site, it appears to be unchanged.

There was a WMC update a few weeks ago, but I did not notice this issue until this weekend.
Please report the following at the close of your email - maybe we can notice a pattern or exclude other variables.

I had just allowed Windows to update.

---------------------------
Platform: Windows 7 64-bit
First noticed: 10/9/11
Last Update: 10/8/11
User avatar
peterc408
 
Posts: 4
Joined: 10 October 2011
HTPC Specs: Show details

Post#6 » Tue Oct 11, 2011 12:29 am

Ill throw my hat in on this one as well. It has only happened to me twice but both times happened yesterday. First time I hit stop during the credits of a tv show and WMC hung stuck on the video of the credits; I had to ctrl-shift-escape to kill WMC and restart it. Second time I hit play on a video and the red spinny circle popped up like normal and just sat there where I briefly heard the audio for the show then WMC hung; had to do the same thing I did after the first hang to correct it.

This is on Windows 7 Ultimate x64, and I have IE9 installed.
jskube
 
Posts: 9
Joined: 26 September 2011

Post#7 » Wed Oct 12, 2011 1:22 pm

+1

Glad to see we're all together on this one team—but who we gonna call (Ghostbusters)?? Seriously, anyone know a proper place to file a bug or anything like that?

For the record, my timeline is about the same as others, and the problem is intermittent.

Interestingly, I'm running x86 but I haven't installed updates since 9/28 (and I think I'll hold off for a minute, but I suppose I could take one for the team and see if it gets 'worse' after I update?)
nikonratm
 
Posts: 1
Joined: 12 October 2011

Post#8 » Wed Oct 12, 2011 7:25 pm

Having the same issue. Haven't done anything to the computer. Just all of the sudden this started happening. Anyone remember the address of the site we all posted on when there were problems previously with this add-on?
Kowolski
 
Posts: 6
Joined: 15 June 2011
HTPC Specs: Show details
1+ YrsTGB Veteran

Post#9 » Wed Oct 12, 2011 11:29 pm

i posted a complaint/description of what is happening here http://techblog.netflix.com/
User avatar
EmirOfGroofunkistan
 
Posts: 151
Joined: 20 June 2011
HTPC Specs: Show details

Post#10 » Thu Oct 13, 2011 8:43 pm

I've found a solution: hit the stop button on your remote control.

http://thedigitalmediazone.com/2011/10/ ... creen-fix/
joshpollard
 
Posts: 5
Joined: 7 September 2011
Josh Pollard
Windows Entertainment and Connected Home MVP
The Digital Media Zone - http://theDigitalMediaZone.com

Post#11 » Thu Oct 13, 2011 9:05 pm

Mine does not go to a black screen and the stop button does not work. Mine sticks on the last frame of the video (or what I assume is the last frame). I can't get anything to fix it except for getting into the task manager and killing ehshell.exe
markterborg
 
Posts: 16
Joined: 13 October 2011

Post#12 » Thu Oct 13, 2011 11:22 pm

Once in a while mine goes to a blank screen, other times it freezes. It's definitely something to do with Netflix since I haven't updated anything.
n8thegr8
 
Posts: 3
Joined: 13 October 2011

Post#13 » Fri Oct 14, 2011 1:02 am

I think the black screen is probably just the final screen for some movies while others have an image or somethings else.

Anyway, when it hits that it freezes media center completely like others here. Pressing the stop button before it gets to the final screen is simply a work around not a solution. But thanks for the input.
User avatar
EmirOfGroofunkistan
 
Posts: 151
Joined: 20 June 2011
HTPC Specs: Show details

Post#14 » Sun Oct 16, 2011 5:53 pm

This problem started a week ago for me. There has been no change to the WMC plugin. I think this is clearly caused by an interface change by netflix.That being said netflix does not support the WMC plugin that is Microsoft. I hope that MS fixes there plugin. To be clear for any netflix/ms employees reading this. I am running WMC7 with the standard netflix plugin. IE9 is installed and runs all pages in compatibility mode.

For those of you on this forum that dont know, the netflix plugin lays over an IE browser window so whichever IE version you have installed is what displays your stream. Further analysis of this popup window at the end of the movies via the browser is in order, depending on how it works it may be able to prevent this with specific settings in your brower. I am certain that the popup is the issue, at the same time the plugin is attempting to return/rerender the listings, the website the plugin is laying over is displaying a dialog which wants to be answered and we end up with some inconsistent state. This is why the task manager reports running instead of not responding. It is possible to lockup the WMC plugin as well by <- out of the video before it ends, let the video end and then try to start another video. These steps lead to the infinite red ring. Sometimes I wish I was a skilled web programmer instead of or in addition to a systems programmer.
binarylogik
 
Posts: 3
Joined: 16 October 2011

Post#15 » Sun Oct 16, 2011 5:54 pm

EmirOfGroofunkistan wrote:I think the black screen is probably just the final screen for some movies while others have an image or somethings else.

Anyway, when it hits that it freezes media center completely like others here. Pressing the stop button before it gets to the final screen is simply a work around not a solution. But thanks for the input.


Correct, the black screen is no different than one with an image, it is just the last frame before we lose control of the plugin.
binarylogik
 
Posts: 3
Joined: 16 October 2011

Post#16 » Sun Oct 16, 2011 6:28 pm

Well looking at the page source and analyzing the messages in wireshark tells me that there is nothing we can do to disable the "back to browsing"/"play next episode" dialog, but didn't this dialog always exist? What is the change to the netflix web interface that was mentioned?
binarylogik
 
Posts: 3
Joined: 16 October 2011

Post#17 » Mon Oct 17, 2011 10:48 pm

Having the same issue. Haven't done anything to the computer. Just all of the sudden this started happening.

Same here..... :cry:
JAJ
 
Posts: 10
Joined: 23 June 2011

Post#18 » Fri Oct 21, 2011 5:22 am

I'm having the same problem. I noticed that it only happens when windows media center is in full screen, in windowed mode it doesn't freeze and simply goes back to the netflix UI.

Happens every single time in full screen though, and I don't really like watching netflix in a window.
Rakeesh
 
Posts: 1
Joined: 21 October 2011

Post#19 » Fri Oct 21, 2011 6:18 pm

I started having the same issue about a week ago. I seldom let videos run to the end but my youngest like the Ruby Gloom cartoon and she doesn't hit the stop button. It freezes once it gets to the end. Some shows run right up to the end and stopping before is not quite possible. I also noticed the freeze prevented my screensaver from coming up as well as prevented my tv from turning off (tv turns off after no activity). The first I can understand the second I can only guess some subtle changes in the frozen frame make the tv think somethings playing. I know a prolonged pause in the NF app will put my tv to sleep.
jedipunk
 
Posts: 6
Joined: 21 June 2011

Post#20 » Sun Oct 23, 2011 5:28 pm

SOLUTION!!
Let me guess, you have MyMovies installed too.
You need to run MyMovies from Media Center and go all the way to the top and turn on the upgrades (both boxes).
Then restart media center. It will tell you that there is an upgrade, install it.
Poof, problem goes away. I have yet to test to see if all the other mymovie weirdnesses have been solved, but I am hopeful.

Post back if it works for you too.
User avatar
peterc408
 
Posts: 4
Joined: 10 October 2011
HTPC Specs: Show details

Next

Return to Windows 7 Media Center



Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron