Sputtering Video Start in Full Screen Only

Sputtering Video Start in Full Screen Only

Post#1 » Sat Nov 24, 2012 2:05 am

Whenever I am running my WMC 7 in full screen, playing back recorded TV (or playing live TV) will cause both video and sound to start normally for a fraction of a second, then the screen goes black and silent for a few seconds, then video and sound resume and the rest of the program is fine. When I stop the playback, the screen again goes black for a second or two before the WMC UI returns.

However, when I do this with a non-full screen WMC window, there is no sputtering start - works perfectly with smooth and seamless video and sound.

I previously had an NVidia GT 8800 that did not exhibit this problem, but it died, and was replaced with an NVidia GT 520. Graphics drivers are up-to-date. Problem appears related to the installation of the GT 520. It is driving a HDMI TV at native 1080p 60hz resolution. I've tried fiddling with various NVidia settings to no avail. Does anyone have any suggestions?

My system is a Dell XPS 420, Intel Q6600, 4GB, Ceton InfiniTV, Win 7 Ult.
golfgeek
 
Posts: 2
Joined: 24 November 2012

Post#2 » Sat Nov 24, 2012 2:41 am

Close Media Center.

From the Windows Desktop..
Open Control Panel
Open Nvidia Control Panel
On the left Click Adjust Desktop Color Settings under Display

On the right Payne..
Set #2 to Use Nvidia Settings
Set #3 Digital Color Format to YCbCr444
Set Content Type Reported to Display to Full Screen Videos
Click Apply in the lower right corner, Confirm the changes when (if) asked.

On the left again click Adjust video color settings under Video
On the right Payne..
#2 set With the Nvidia Settings
Advanced Tab set Dynamic Range to Full (0-255)
Click Apply lower Right Corner, Confirm the changes when (if) asked.
Exit Nvidia and Windows control Panels.

Open Media Center and that should fix the problem and give you better color on the TV as well.
Also doesn't hurt to update DirectX here: http://www.microsoft.com/en-us/download ... aspx?id=35
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#3 » Sat Nov 24, 2012 3:25 am

Thanks newfiend - that solved it. More specifically, setting the "Adjust Desktop Color Settings under Display/Content Type Reported to Display" to "Full Screen Videos" was all that was required to solve the sputtering problem. The only tradeoff is the desktop looks a little less sharp when not running WMC.

Thanks for your additional suggestions to improve the color. I like the full dynamic contrast in the video color settings, but prefer disabling the color enhancement option - some colors were getting oversaturated in my case.

Glad to see the 'new' Green Button is alive and well!
golfgeek
 
Posts: 2
Joined: 24 November 2012

Post#4 » Sat Nov 24, 2012 3:51 am

The Desktop typically doesn't look as good. But TV Viewing will be much improved (usually better color depth with Dynamic Range set to 0-255) .. Do what works best for you. I know that Content Type Reported would fix your flicker issue. It has for me on multiple NVidia cards.
Glad it worked for you as well.
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#5 » Sun Nov 25, 2012 2:55 pm

Mine started doing exactly this when I added an AVR between the HTPC and the TV. It doesn't bother me too much, but it would be nice to get rid of this behavior.

I tried the settings that newfiend recommended, and it didn't change the behavior at all.

EDIT: To be correct, I should say that mine does exactly this at the beginning of playing TV/RecordedTV. It does not do it at the end when I press stop to go back to the menu.
barnabas1969
 
Posts: 5740
Joined: 21 June 2011
Location: Titusville, Florida, USA
HTPC Specs: Show details
2+ YrsTGB Veteran

Post#6 » Mon Nov 26, 2012 4:38 am

barnabas1969 wrote:Mine started doing exactly this when I added an AVR between the HTPC and the TV. It doesn't bother me too much, but it would be nice to get rid of this behavior.

I tried the settings that newfiend recommended, and it didn't change the behavior at all.

EDIT: To be correct, I should say that mine does exactly this at the beginning of playing TV/RecordedTV. It does not do it at the end when I press stop to go back to the menu.

Usually setting Content Type Reported to Display to Full Screen Videos will stop the Screen from Blanking (Going completely black then popping back on Full Screen) issue. Is that what's happening to you Brian?
Are the settings sticking after rebooting/Powering down and back up the PC in Nvidia Control Panel? (Content type still set at full screen videos?)

If the settings are not sticking let me know.. It could depend on the boot sequence between TV,AVR and PC with the Nvidia Card not retaining the EDID data.. Selecting the correct Boot sequence or installing the HDMI Detective should correct the problem as then the Nvidia Card thinks the display is "always connected". What order do your components power on? Tv,AVR, PC?
napalm in this thread is having this issue viewtopic.php?f=7&t=1637&p=34412#p34412
he has a Yamaha AVR... is your AVR Yamaha as well? is it up to date on firmware? (TV and AVR)
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#7 » Tue Dec 04, 2012 9:58 pm

Thank you so much for this thread. My problem was a bit worse.

Watching a lot of native 1080i programs on CBS and Science channel, my display would reset showing me which input it was tuned to. It happened several times a minute to several times per program depending on something I really don't know.

I was pulling my hair out with that because the only ota programming I watch is on CBS.

Can't thank you enough for this fix. I was NOT the original poster but I still think it needs to be thanked again!
AnthonyB
 
Posts: 40
Joined: 11 October 2012

Post#8 » Wed Dec 05, 2012 8:54 pm

newfiend wrote:
barnabas1969 wrote:Mine started doing exactly this when I added an AVR between the HTPC and the TV. It doesn't bother me too much, but it would be nice to get rid of this behavior.

I tried the settings that newfiend recommended, and it didn't change the behavior at all.

EDIT: To be correct, I should say that mine does exactly this at the beginning of playing TV/RecordedTV. It does not do it at the end when I press stop to go back to the menu.

Usually setting Content Type Reported to Display to Full Screen Videos will stop the Screen from Blanking (Going completely black then popping back on Full Screen) issue. Is that what's happening to you Brian?
Are the settings sticking after rebooting/Powering down and back up the PC in Nvidia Control Panel? (Content type still set at full screen videos?)

If the settings are not sticking let me know.. It could depend on the boot sequence between TV,AVR and PC with the Nvidia Card not retaining the EDID data.. Selecting the correct Boot sequence or installing the HDMI Detective should correct the problem as then the Nvidia Card thinks the display is "always connected". What order do your components power on? Tv,AVR, PC?
napalm in this thread is having this issue viewtopic.php?f=7&t=1637&p=34412#p34412
he has a Yamaha AVR... is your AVR Yamaha as well? is it up to date on firmware? (TV and AVR)
newfiend~

Sorry, I was on vacation... and the number of posts regarding the Echo buried this thread.

Anyway... I didn't try rebooting the PC after I made your recommended changes, so I don't know. All I know is that it didn't change the behavior. Should I have booted the PC after making the changes?

As for the power-up sequence... it usually goes... TV, PC, AVR. That's because I'm using the HDMI-CEC bridge from RCAware. The TV needs to turn on first. This triggers the HDMI-CEC bridge to wake the PC. Then, the PC sends a command to the AVR to turn it on. The AVR is set for HDMI passthru, so the PC's desktop is displayed on the TV until the AVR turns on and Media Center starts.
barnabas1969
 
Posts: 5740
Joined: 21 June 2011
Location: Titusville, Florida, USA
HTPC Specs: Show details
2+ YrsTGB Veteran

Post#9 » Wed Dec 05, 2012 11:12 pm

Try setting the settings listed above.. Click Apply in the lower right corner. Close Nvidia Control panel and Reboot.
After rebooting go back into Nvidia Control Panel and see if Full Screen Videos setting is still selected.. If it did not retain the setting let me know. (I'm more curious than anything) .. If you can get that setting to stay it should correct the screen blanking issue if that's what is happening to you.
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#10 » Tue Dec 11, 2012 3:56 pm

I set all of your settings, except that I disagree about dynamic range... it should be set to 16-235 because this is how all TV broadcasts are recorded, and very few Bluray discs have "deep blacks" (0-15) or "whiter than white" (236-255). Forcing it to full range will actually cause colors to be incorrect for content that was recorded with a range of 16-235.

I also disabled Dynamic Contrast and the color enhancement thing (these are not enabled when the settings are all set to "use the player's settings").

I rebooted, and my settings stayed the way I set them. Unfortunately, it still goes black momentarily when I start to play a show. I'm convinced this is due to my AVR. It didn't do this before I put an AVR between the TV and PC.

Still though, it's not a big deal.
barnabas1969
 
Posts: 5740
Joined: 21 June 2011
Location: Titusville, Florida, USA
HTPC Specs: Show details
2+ YrsTGB Veteran

Post#11 » Wed Dec 12, 2012 1:25 am

You can leave Dynamic range to the “Limited” default setting if it works better for your display. Dynamic range doesn’t appear to have an impact on HQV scoring, but the Full setting does provide a wider range of brightness between white and black if it's appropriate for your display.
Most televisions expect a 16-235 signal range, while monitors expect a 0-255 range. Choosing an inappropriate range can cause a loss of contrast but I find on my TV that the color is better and less "washed out" looking for lack of a better term. It will depend on your display and what works best for you. Strange that you still get the screen blanking, hopefully a firmware update for your avr down the line fixes that for you.
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#12 » Wed Dec 12, 2012 2:48 am

It's true that it will make the black, gray, and white rendering have a bigger range in some cases. However, it will also affect your color accuracy. My TV can handle the full range of 0-255 ("blacker than black", and "whiter than white"). The problem is that most CONTENT (the TV shows and movies... probably more than 99% of what is available to watch) is produced with the 16-235 range, because most TV's cannot handle values between 0-15 and 236-255. So, if you set your TV and/or display adapter to the 0-255 range, there is a mismatch between the source material and the way you are displaying it. It doesn't only affect the whites and blacks... it affects all of the colors in between.

You've gotta understand... the numbers (0-255) apply to each of the three colors (red, green, blue). This is what gives a computer monitor 16 million colors (actually 256^3, or 16,777,216, a.k.a "16 million colors"). You see, there are 256 levels of each color (0-255) on a computer monitor (and many high-end TV's). When all three colors are set to the same value, your eye perceives them as white. When all three colors are set to the maximum value (255, 255, 255 --decimal-- in RGB ... or FF, FF, FF in hexadecimal) you perceive them as the brightest white.

But, let's consider the fact that all broadcast TV shows (and more than 99% of movies) are shot in the limited 16-235 range. If you set your dynamic range to 0-255 (assuming that your TV can handle it), your TV may display a wider range of blacks and whites. That would be wonderful if we watched black-and-white TV. However, since most programming is shot in the limited range (and in COLOR), it distorts the color of the displayed image.

Let me explain it to you this way... we all know that yellow and blue makes green. If you add EQUAL amounts of yellow and blue to a piece of white paper, and shine a white light on it, you get green, right? Well, that's true for subtractive colors. Those are colors that are applied to surfaces that reflect light to our eyes, like paper. We also know that the primary colors are red, blue, and yellow... right?

That's the subtractive color model.

Well, a television doesn't work on the subtractive color model. It works on the additive color model. Ever wonder how a TV can display the color YELLOW, when it only has red, blue, and GREEN to work with? Well, in the additive color model, when you mix EQUAL amounts of the color green and red, you get.... (drum roll please)... yellow! The primary colors in the additive color model are Red, Green, and Blue (RGB).

Well, let's say that you're watching a TV show... and they filmed a perfectly yellow wall that is brightly lit. Now, remember... they almost always film stuff in the 16-235 range (10,648,000 colors, or 220^3... because 235-16+1=220). The original source material will contain pixels that are coded as 235,235,0 (R,G,B) to make pure, bright, yellow.

The problem is... your video adapter is set to 0-255. What happens when it receives content that contains 235,235,0?

Well, there are four possibilities, depending on your TV's (display device) and video adapter's behavior ...

A) The video adapter will simply pass the 16-235 range to the display device without converting it to 0-255. The display device will chop off everything above 235, and below 16... resulting in the same picture as the director intended.

B) The video adapter will convert the 16-235 range to 0-255. The display device will chop off everything above 235 and below 16... resulting in a loss of color accuracy and a loss of contrast ratio. Black (16,16,16) gets converted to 0,0,0... and that's fine... the TV will truncate it and display 16,16,16 anyway... still black. But what happens when the color is different... let's say 32,32,32? Let's assume that the video adapter converts that to 16,16,16. So... both are displayed as black... making you lose the shadow detail.

C) The video adapter will pass the 16-235 range to the display device without converting it to 0-255. The display device will display the full range of 0-255. This will result in color accuracy that is incorrect, and the contrast ratio will also suffer, because the original content expects black to be 16,16,16... but the display shows 16,16,16 as gray! (because it expects black to be 0,0,0) And the content expects 235,235,235 to be white... but the display expects 235,235,235 to be gray too! (because it expects white to be 255,255,255)

D) The video adapter will convert 16-235 from the content to 0-255, and the display will display it as 0-255 without chopping it. This will result in an expanded scale of black-to-white (gray scale), but a color that doesn't match the director's intent. It will be very close, but no cigar.

So, you have a 25% chance of getting it right by forcing the dynamic range to 0-255. Since more than 99% of content is filmed in 16-235, it's safer to either A) leave it set to "set by player" or B) set it to 16-235. Hopefully, if you choose option "A", your player (Media Center, PowerDVD, TMT, etc) will be able to detect when you are playing a Bluray (or Bluray rip) that is actually encoded in 0-255. But, that's a rare case. Most DVD's and Blurays are encoded in 16-235, and so is broadcast TV. You're much safer allowing the player to set the dynamic range, or just force it to 16-235... because that's how the vast majority of content is filmed.

I hope that makes sense.
barnabas1969
 
Posts: 5740
Joined: 21 June 2011
Location: Titusville, Florida, USA
HTPC Specs: Show details
2+ YrsTGB Veteran

Post#13 » Wed Dec 12, 2012 5:29 am

It does.. I changed my settings to 16-235 range. ran a few video tests and didn't see much of a change thus far. I think the biggest display difference I can see is from switching from RGB to YCbCr444. If I leave it at RGB my display looks really washed out. YCbCr444 gives me much better picture on my TV over HDMI.
Have you seen this over at HACK7MC? http://www.hack7mc.com/2009/06/fixing-m ... evels.html
newfiend~
User avatar
newfiend
 
Posts: 2195
Joined: 7 June 2011
Location: Earth
HTPC Specs: Show details
5+ YrsTGB Veteran

Post#14 » Wed Dec 12, 2012 5:52 am

Well, when you connect a TV, it should be set to YCbCr444 (and the TV should NOT be set to the RGB/computer/game mode). The display adapter should only be set to RGB when you connect a computer monitor.

I've seen stuff that is similar to that post on Hack7MC. It looks right to me... except that I wouldn't recommend setting it to 0-255. There is so little content that was filmed in 0-255, there's really no reason to ever enable that on the display adapter (unless you play games, of course). Changing this will, of course, affect the calibration of your TV. However, after calibration, you'll get more accurate results with more than 99% of content if you choose the 16-235 setting.
barnabas1969
 
Posts: 5740
Joined: 21 June 2011
Location: Titusville, Florida, USA
HTPC Specs: Show details
2+ YrsTGB Veteran

Post#15 » Wed Dec 12, 2012 4:28 pm

Interesting post. Cant wait to get home to try it out on my new TV :)
mm60
 
Posts: 9
Joined: 13 June 2011


Return to Windows 7 Media Center



Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests

cron