Restore network browsing w/out SMBv1? Heres how

Talk about setting up your home network.

Restore network browsing w/out SMBv1? Heres how

Post#1 » Mon Mar 12, 2018 5:09 pm

Taken from RoderickGI on the JRiver Forums found here: https://yabb.jriver.com/interact/index. ... 852.0.html

This will not be a thorough description, but hopefully points users in the right direction if they have lost the ability to Browse their Local Area Network or what used to be known as Network Neighbourhood. If you know what you are doing, just do what the Blue writing says. Otherwise, read the detail.

Background:
In a recent update to Windows 10, taking it to Version 1709, OS Build 16299.248, Microsoft disabled the SMBv1 (also known as Samba Version 1) feature. The Network Neighbourhood functionality relied on SMBv1 to work, so it stopped working. You could no longer browse your local network to find other PCs and Shares you had set up on those PCs. Very annoying. Microsoft failed to tell anyone how to get the browsing functionality back. Even more annoying. The internet is littered with questions, answers (many of them wrong), and lots of frustration as a result.

Using SMBv1 is bad, as it is full of security holes. So turning it off was a good idea. Not turning on the Services that provide equivalent functionality using the more secure SMBv2 and SMBv3, or more correctly the WS-DISCOVERY protocol, was not a good idea. Shame on you Microsoft.

Solution:
The fix to return Network Browsing capability is actually pretty easy. It doesn't need SMBv1, so don't turn that on as suggested by some.

First, open the Service App and change the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services to a Startup Type of Automatic (Delayed Start). This was eventually documented with even more words than I usually use on this page: https://support.microsoft.com/en-au/hel ... rsion-1709

Second, make sure that the network that you want to browse is a Private Network. This can be a little tricky, particularly if you are using a non-Administrator UserID in Windows 10, as I was on my HTPC. My network had been set to "Public" because I was using a VPN, which makes sense, and changing it back to "Private" once I closed the VPN was quite a challenge. Microsoft in their infinite wisdom have removed the setting from the obvious places, to protect you from making a mistake, no doubt. But there are many posts on the internet on how to do this. If you need more information I recommend only using suggestions from Microsoft sites, or the ten forums. This is a good thread, but very long: https://www.tenforums.com/tutorials/681 ... -10-a.html

On my Workstation with Administrator privileges this was as easy as going to;
Start - Settings - Network & Internet - Ethernet - click your Adapter - another screen will pop up - change the Network Profile to "Private". But that option wasn't available on my HTPC.

My easy solution was to open the "Network and Sharing Center" in the Windows Control Panel and click on the "HomeGroup" link at the bottom left. See the Red arrow in the first image. Windows then asked if I wanted to change my network from Public to Private. Or more correctly asked if I wanted the network to be discoverable. See the second image. Note that you do not need to create a HomeGroup, and unless you really want one, or know what you are doing, I recommend that you don't. Microsoft is going to remove HomeGroups soon anyway, and I found the HomeGroup functionality to be rubbish.

Do not edit the Registry or change Windows Policies to fix this issue unless you really know what you are doing. You may find there are some unexpected consequences, like your network doesn't change to Public when it needs to.

Third, turn on "Network Discovery" with "Automatic setup of network connected devices" for your Private LAN. This is done in the "Advanced sharing settings" of "Network and Sharing Center" in the Windows Control Panel. See Green arrow in the first image below.

There are a lot of discussions on the internet regarding how to get to and make these changes, but just set up your network connection as per the third image below.


That's it. You should now be able to browse your local area network again. I hope this helps.
jachin99
 
Posts: 726
Joined: 24 February 2016

Return to Networking / Windows Home Server



Who is online

Users browsing this forum: No registered users and 1 guest

cron